Skip to content

Commit

Permalink
dev-games/simgear: Fix boost TR1 header include
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/630234
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
SoapGentoo committed Sep 16, 2017
1 parent 4f719a7 commit 4535ab5
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 6 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
--- a/simgear/scene/material/Effect.cxx
+++ b/simgear/scene/material/Effect.cxx
@@ -32,7 +32,7 @@
#include <map>
#include <queue>
#include <utility>
-#include <boost/tr1/unordered_map.hpp>
+#include <boost/unordered_map.hpp>

#include <boost/bind.hpp>
#include <boost/foreach.hpp>
@@ -832,13 +832,13 @@

// XXX Should these be protected by a mutex? Probably

-typedef tr1::unordered_map<ProgramKey, ref_ptr<Program>,
+typedef boost::unordered_map<ProgramKey, ref_ptr<Program>,
boost::hash<ProgramKey>, ProgramKey::EqualTo>
ProgramMap;
ProgramMap programMap;
ProgramMap resolvedProgramMap; // map with resolved shader file names

-typedef tr1::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
+typedef boost::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
ShaderMap;
ShaderMap shaderMap;

--- a/simgear/scene/material/Effect.hxx
+++ b/simgear/scene/material/Effect.hxx
@@ -19,7 +19,7 @@

#include <vector>
#include <string>
-#include <boost/tr1/unordered_map.hpp>
+#include <boost/unordered_map.hpp>

#include <boost/functional/hash.hpp>

@@ -127,7 +127,7 @@
bool operator()(const Key& lhs, const Key& rhs) const;
};
};
- typedef std::tr1::unordered_map<Key, osg::observer_ptr<Effect>,
+ typedef boost::unordered_map<Key, osg::observer_ptr<Effect>,
boost::hash<Key>, Key::EqualTo> Cache;
Cache* getCache()
{
17 changes: 11 additions & 6 deletions dev-games/simgear/simgear-2017.2.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,15 +3,15 @@

EAPI=6

inherit eutils cmake-utils toolchain-funcs
inherit cmake-utils toolchain-funcs

DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/"
SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"

LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+dns debug gdal openmp subversion test"

COMMON_DEPEND="
Expand All @@ -31,12 +31,17 @@ RDEPEND="${COMMON_DEPEND}
subversion? ( dev-vcs/subversion )
"

PATCHES=( "${FILESDIR}/simgear-2017.2.1-gdal-underlinking.patch" )

DOCS=(AUTHORS ChangeLog NEWS README Thanks)
PATCHES=(
"${FILESDIR}"/${PN}-2017.2.1-gdal-underlinking.patch
"${FILESDIR}"/${PN}-2017.2.1-boost-1.65-tr1-removal.patch
)

pkg_pretend() {
use openmp && tc-check-openmp
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

src_configure() {
Expand Down

0 comments on commit 4535ab5

Please sign in to comment.