Skip to content

Commit

Permalink
app-shells/thefuck: version bump to 3.27 and EAPI=7.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Closes: gentoo#8568
  • Loading branch information
holgersson32644 authored and monsieurp committed May 24, 2018
1 parent 917a50a commit 4744eed
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/thefuck/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST thefuck-3.24.tar.gz 1360450 BLAKE2B 38a4a0484220eb92e75d164958f7a1db9d3828268a352da7a99ea79487869a39c88cdb65a315a49f71cd70a8d3ce488b1b692c241dff7329fc27c16ba33ce81f SHA512 d4949ea723cf3b080f2fbe269d0cafe3d0266089fa8cc515b3b9376b2004c045be82716cd219741a60a0e99c20575adb92339a879467f709f7ca03dcc71a5c2d
DIST thefuck-3.25.tar.gz 1362279 BLAKE2B 52b3f1c8756b6981c0528fd77c18256957dd5d628ea37801b9c9abf6114e1cef8af53d9d1dd50fc7c88fad7bd628dc8373aa70dbc6933c07c63b7da31eb5d95a SHA512 c7b215358c09e1fa5e6aae519e7d6c3fd50027b4c72bb1c128786cd2cff707196f2b9b2a23dfed34d841874caab9463791e82c9083f6aac9c90f26d12a4d4598
DIST thefuck-3.26.tar.gz 1365778 BLAKE2B 3266fc5a1e351df1ccd13bfb6def6254194a05a94c7bf2bdcafb9c75414fce23b479eb1ac866333e8aef7d51bc609fc00aad8508e4cf0f0d959632744330e734 SHA512 2dbcc7ba0adb24b3f7d80d0c575a4ed515508e0ab5bc2fc4eb9ba82ad36325af1784eb9c241794ce0e038ed8e99042eb21cc3b29eeaa273517aebc7205ab787f
DIST thefuck-3.27.tar.gz 1367120 BLAKE2B a840ac3e8f6807df632948e2fe2789a47bdcfececfd4a9bb0f1836bbaa641501e13c559221b9a2f25bbd93505c8b03db102636e480ece116a42c46f341d5cd35 SHA512 766c589f0e99a9773e74094e91c6a74d00e5be8b7241680ad664ecc3f549b597416bc7a4d289f399ed3a0d9ccad629ed78bb983edc809664c303c687ea1eec1a
41 changes: 41 additions & 0 deletions app-shells/thefuck/thefuck-3.27.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{4,5,6} )

inherit distutils-r1

DESCRIPTION="Magnificent app which corrects your previous console command"
HOMEPAGE="https://github.com/nvbn/thefuck"
SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/pyte[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)"

python_prepare_all() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die

distutils-r1_python_prepare_all
}

python_test() {
py.test || die
}

0 comments on commit 4744eed

Please sign in to comment.