Skip to content

Commit

Permalink
sys-process/criu: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
dlan17 committed Aug 25, 2016
1 parent c531940 commit 47f05b4
Show file tree
Hide file tree
Showing 3 changed files with 114 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-process/criu/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST criu-2.2.tar.bz2 558926 SHA256 f893938f72d2c0693a9430e7dd39dc3d32a40187de5edbd65830c6ade0f34e53 SHA512 3e03dcd3531641e93f88354515b902390a9d83fd79eec36848ded5a28e987cd5ae8e81d7ed645960a86f4dfa5176f17de02f5a9b19723a8aaa2bf15057fe46dd WHIRLPOOL 62bf41089f0028926622ba69c5c6f44f0ee8288a38b2d6ce82e9c727c9ee9ccd1f65a6a8654c9faa06597316e8b00b6076b4cddf6d7af06b85f8de334de9afa7
DIST criu-2.3.tar.bz2 572580 SHA256 acbdfeb2b6c5b72dbc849e014eecd4d166f0c05c76fc40424eedec0761b60bfe SHA512 b058d4a917363190f5196256ecff23fab7c11e259807d8cef954690e9bc03751095529da5774e687ff6a1a506382aec92275771b031d790d6a0bd7cebde2916a WHIRLPOOL a32809d05d01781b3241f4c6766f8d17acc8de275af01d934e849a47f8857d4479147dc127cc02e32ebb6358720536e1596b6e063fdc88ee1c0b0725e126220f
DIST criu-2.4.tar.bz2 602896 SHA256 2a38119d7baae2cad8496f98dfc461c9685e67f12131abc5f44d764d4b87e9f0 SHA512 04f1ba472ea9189250f1eedbf377b2607f8425cc660b37e1ca8b47310eec84331551f5c3db1b7341779176aaeaaab67662545dad2ffbcf212548c67a991b0c72 WHIRLPOOL 9447a3e542beced07636269c7c6612080ecd6d4edb2bb09459440fc8a517bb08dd385bde6c80d5cc61dbf90948b740aa80bdae6bcd79b8415ae3d4fdec4413cd
DIST criu-2.5.tar.bz2 605226 SHA256 d2a9ffec0b659c3d3a71e1d473e95e36b208b2563f136ce8f471ff9600fcc51a SHA512 ccf942005ff3b2a567726ddb8aa44048c130f1adf6e2cbdf48e919043c84a4e1c03ad0ec34b44263e5764bea62807a2cc0fa1135b929ad3166fb9486c2880570 WHIRLPOOL 9896fe45d4516a73e6b7c403a044d25902ed4a9000b0a0a053ff9d52c053adfb58c8ce0225b9841bc7e2f38de6a8e4fc6d3073d878ea5b09b81cc89cba91de62
96 changes: 96 additions & 0 deletions sys-process/criu/criu-2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit eutils toolchain-funcs linux-info flag-o-matic python-r1 python-utils-r1

DESCRIPTION="utility to checkpoint/restore a process tree"
HOMEPAGE="http://criu.org/"
SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
IUSE="python setproctitle"

RDEPEND="dev-libs/protobuf-c
dev-libs/libnl:3
sys-libs/libcap
python? ( ${PYTHON_DEPS} )
setproctitle? ( dev-libs/libbsd )"
DEPEND="${RDEPEND}
app-text/asciidoc
app-text/xmlto"
RDEPEND="${RDEPEND}
python? (
dev-libs/protobuf[python,${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
)"

CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"

RESTRICT="test"

PATCHES=(
"${FILESDIR}"/2.2/${PN}-2.2-flags.patch
"${FILESDIR}"/2.4/${PN}-2.4-makefile.patch
"${FILESDIR}"/2.3/${PN}-2.3-no-git.patch
"${FILESDIR}"/2.5/${PN}-2.5-automagic-libbsd.patch
"${FILESDIR}"/2.0/${PN}-2.0-sysroot.patch
"${FILESDIR}"/2.3/${PN}-2.3-aarch64.patch
)

criu_arch() {
# criu infers the arch from $(uname -m). We never want this to happen.
case ${ARCH} in
amd64) echo "x86";;
arm64) echo "aarch64";;
*) echo "${ARCH}";;
esac
}

src_compile() {
RAW_LDFLAGS="$(raw-ldflags)" emake \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
OBJCOPY="$(tc-getOBJCOPY)" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
ARCH="$(criu_arch)" \
V=1 WERROR=0 DEBUG=0 \
SETPROCTITLE=$(usex setproctitle) \
PYCRIU=$(usex python) \
all docs
}

src_test() {
# root privileges are required to dump all necessary info
if [[ ${EUID} -eq 0 ]] ; then
emake -j1 CC="$(tc-getCC)" ARCH="$(criu_arch)" V=1 WERROR=0 test
fi
}

install_crit() {
"${PYTHON:-python}" ../scripts/crit-setup.py install --root="${D}" --prefix="${EPREFIX}/usr/"
}

src_install() {
emake \
ARCH="$(criu_arch)" \
PREFIX="${EPREFIX}"/usr \
LOGROTATEDIR="${EPREFIX}"/etc/logrotate.d \
DESTDIR="${D}" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
install

dodoc CREDITS README.md

if use python ; then
cd lib
python_foreach_impl install_crit
fi
}
17 changes: 17 additions & 0 deletions sys-process/criu/files/2.5/criu-2.5-automagic-libbsd.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
diff --git a/criu/Makefile.config b/criu/Makefile.config
index f531b3b..23a3b23 100644
--- a/criu/Makefile.config
+++ b/criu/Makefile.config
@@ -2,10 +2,12 @@ include $(__nmk_dir)/utils.mk
include $(__nmk_dir)msg.mk
include $(SRC_DIR)/scripts/feature-tests.mak

+ifeq ($(SETPROCTITLE),yes)
ifeq ($(call try-cc,$(FEATURE_TEST_LIBBSD_DEV),-lbsd),true)
LIBS += -lbsd
FEATURE_DEFINES += -DCONFIG_HAS_LIBBSD
endif
+endif

ifeq ($(call pkg-config-check,libselinux),y)
LIBS += -lselinux

0 comments on commit 47f05b4

Please sign in to comment.