Skip to content

Commit

Permalink
dev-lang/mono: bump into 4.8.0.524
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
cnd committed Apr 2, 2017
1 parent 98f8656 commit 488b0f0
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/mono/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mono-4.4.1.0.tar.bz2 85897587 SHA256 165e7686b5cbb1ab671b4cb2069207999c3d70
DIST mono-4.6.1.5.tar.bz2 83174665 SHA256 3871ee72bdfc2ea5d636ffff22cf49ae6bac7c4a4f3d687214dd8ac236bbf7c3 SHA512 1d0c1ec2930ecea3faf1be572bc045300ef4a90d3fe7519f2a9c797be79298c61528d83baa5a24a57143a35be80f78297196556c33cd0f345d9907a973fe625a WHIRLPOOL 9ccfdfa68f2d9a75440c71fb22af988165608299d7aaeecac77fc783412cba4524a423b166a540d2381c98c58e3f7e40ada91381d45f67693e1f69e462bbb1d9
DIST mono-4.8.0.425.tar.bz2 87955541 SHA256 0d81ba0ef69fbfa2ac8206c9e7a0ad996c193c06c897bab36c5dcc4a40b50a7d SHA512 7bab64adbebc277d3fc10301fa6af6cd64ea0836e2d74dfdd9b59684d9402689f9a4e397f3d36f519c7a892c14dcf8f8867d40a5119891874dfd10f9bbce2ac4 WHIRLPOOL fcb095e83880bdbbce6978af68c5997f1f345046307e3ea4d53413b257dca7953b947c90e073e15991ec043483982bfcf28d29c350e392e534c865b74fff8a89
DIST mono-4.8.0.495.tar.bz2 87540431 SHA256 7ba62e6f42559d58dc447a19fc1cb2a9c7977d6c6e21e1e335f73917dea120cb SHA512 0052b7b04ae25e7cb5970d742369b74c83a10c6c82da591e8d26ad9e13e8b2590a1cde27ca99e43aebc622c7a2a590b9e6c7ce519ac4185b0b6cf7134527cc9d WHIRLPOOL 54c7101dbb2b886d9798e16cbf0e84898f9d4a96786d9f52f76a9872f99ac1b39d1f6109abcfc70897163bab3e5b3478ecb77ef217953118badc537e8e474e5e
DIST mono-4.8.0.524.tar.bz2 87392723 SHA256 ca02614cfc9fe65e310631cd611d7b07d1ff205ce193006d4be0f9919c26bdcf SHA512 eb77b768a4a26e6a2a872f4845769cdc83f01af3377ecd6d932437d2a1b54bfd1ce727563906146195a54997b4b624fb75449a6f0bcfe818cbc4e6544841bf2b WHIRLPOOL 143232c15b99e702de5774a0ffbcf6f3ee85338b55e8f0cc7de2afe6053e7de62cccd3cc27163213e492851c13cdfbe0e244a4f8f0824e4786c658a2a81ac477
111 changes: 111 additions & 0 deletions dev-lang/mono/mono-4.8.0.524.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal

DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.mono-project.com/Main_Page"
SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"

LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"

KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"

IUSE="nls minimal pax_kernel xen doc"

COMMONDEPEND="
!minimal? ( >=dev-dotnet/libgdiplus-2.10 )
ia64? ( sys-libs/libunwind )
nls? ( sys-devel/gettext )
"
RDEPEND="${COMMONDEPEND}
|| ( www-client/links www-client/lynx )
"
DEPEND="${COMMONDEPEND}
sys-devel/bc
virtual/yacc
pax_kernel? ( sys-apps/elfix )
dev-util/cmake
!dev-lang/mono-basic
"

PATCHES=(
"${FILESDIR}"/${PN}-4.8.0.371-makedev.patch
"${FILESDIR}"/${PN}-4.8.0.371-x86_32.patch
)

S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"

pkg_pretend() {
linux-info_pkg_setup
if use kernel_linux; then
if linux_config_exists; then
linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
else
# https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
ewarn "kernel config not found"
ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
ewarn "See http://bugs.gentoo.org/261869 for more info."
fi
fi
}

pkg_setup() {
mono-env_pkg_setup
}

src_prepare() {
# we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
# get killed in the build proces when MPROTECT is enable. #286280
# RANDMMAP kill the build proces to #347365
# use paxmark.sh to get PT/XT logic #532244
if use pax_kernel ; then
ewarn "We are disabling MPROTECT on the mono binary."

# issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
fi

# mono build system can fail otherwise
strip-flags

#TODO: resolve problem with newer binutils
#bug: https://bugs.gentoo.org/show_bug.cgi?id=600664
#append-flags -fPIC

default
# PATCHES contains configure.ac patch
eautoreconf
multilib_copy_sources
}

multilib_src_configure() {
local myeconfargs=(
--disable-silent-rules
$(use_with xen xen_opt)
--without-ikvm-native
--disable-dtrace
$(use_with doc mcs-docs)
$(use_enable nls)
)

econf "${myeconfargs[@]}"
}

multilib_src_test() {
cd mcs/tests || die
emake check
}

multilib_src_install() {
default_src_install

# Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
# mono.spec and http://www.mail-archive.com/[email protected]/msg24870.html
# for reference.
rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
}

0 comments on commit 488b0f0

Please sign in to comment.