Skip to content

Commit

Permalink
gnustep-libs/sope: Version bump (thanks bgo for noticing, bug 615354).
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
xmw committed Apr 15, 2017
1 parent aa4c17a commit 491a8eb
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnustep-libs/sope/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST sope-3.2.1.tar.gz 2195142 SHA256 654b72d87207568808665603557b9e7d311b558eee4ae9229479eb9918362d4c SHA512 bf1ead8bc8759d7fd6acf8b7fbff91718070e6f6a1e4fff24b1c0b37128ebf9542e8158e80ca12e8e60770ac1207c5825b8e0032a175ef6f102392f5f8cd7e09 WHIRLPOOL 10949992319dc45eaeeaaa03090997767b2b3bf9f2001a6804e6beae8038b87a4c14d30ffb7754f027d77f8631dea1c6414462870ac4f690860710d92da3bd0e
DIST sope-3.2.6a.tar.gz 2196322 SHA256 b01e2fdadfa8db81af462fd4622251de0547359af706bbe7b7cf958b0eed350a SHA512 b1f56f7fb61ee9b95cb5cfcc362cfe72312f9e90fe669904b2f341f42fb2f4299a2449437b6c23c1db316005dfa05ef8d163cadbc271f9821e64d7269afb73ef WHIRLPOOL c13825861ee8a49e03dfaef0cb3b6bc93015d287253753cf288348128831827ca99f59854f40b740180f7634a2a2c6af2cb8008a62afcb66954027bd71053139
DIST sope-3.2.8.tar.gz 2196618 SHA256 f70cea6b07c73e2e448c8e382a12c50bfa8d2dc79908e2b3b3c08faab7756bba SHA512 cecb4bf3ae78afbb210a3295ff4bcbf7d3a547fec6378fcda976ff2bd1c5d805d57a6c30ec5eaf61bceb580982af4f0402ac0895ad3b7f4695cdb1ceb0160f50 WHIRLPOOL 522426e7f1c9cd5d920fe42588d10b405343f827cd4a948570824e77b03313618f38f507a2a3a938ea203c7a93fa2d84bd67a7eb827bdfa9a7f0f6658bf7a9e5
62 changes: 62 additions & 0 deletions gnustep-libs/sope/sope-3.2.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils gnustep-2 vcs-snapshot

DESCRIPTION="A set of frameworks forming a complete Web application server environment"
HOMEPAGE="http://www.sogo.nu/"
SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnutls ldap libressl mysql postgres +ssl +xml"

RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
mysql? ( virtual/libmysqlclient:= )
postgres? ( dev-db/postgresql:= )
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}"

pkg_pretend() {
if use ssl && use gnutls && use libressl ; then
ewarn "You have enabled both gnutls and libressl, but only"
ewarn "one provider can be active. Using gnutls!"
fi
}

src_configure() {
local ssl_provider
if use ssl ; then
if use gnutls ; then
ssl_provider=gnutls
else
ssl_provider=ssl
fi
else
ssl_provider=none
fi

egnustep_env

# Non-standard configure script
./configure \
--disable-strip \
$(use_enable debug) \
$(use_enable ldap openldap) \
$(use_enable mysql) \
$(use_enable postgres postgresql) \
$(use_enable xml) \
--with-ssl="${ssl_provider}" \
--with-gnustep || die "configure failed"
}

0 comments on commit 491a8eb

Please sign in to comment.