Skip to content

Commit

Permalink
media-libs/libopenglrecorder: new package
Browse files Browse the repository at this point in the history
This library is an optional dependency for
>=games-action/supertuxkart-0.9.3
  • Loading branch information
fx-carton authored and chewi committed Dec 26, 2017
1 parent 1dbae97 commit 49c50fd
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libopenglrecorder/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST libopenglrecorder-0.1.0.tar.gz 101788 BLAKE2B 9fbd9e5acb51c033f533166cf4f55863d97331ca0d506ada7f0e2ffaf790a20b74521668d80dfe4ef230a6bf44466b5f5eda9ab6d4a248db730b0596ce441f6f SHA512 2264b5999870d89ab10366bbbbccfce8ef7c2674bb054005f4e182af2cb10c7553f97402feadc528da94608a47db030a07987b11470044965d70cd69fe47bacd
38 changes: 38 additions & 0 deletions media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="A library allowing optional async readback OpenGL frame buffer with optional audio recording"
HOMEPAGE="https://github.com/Benau/libopenglrecorder"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="vpx openh264 -pulseaudio"

DEPEND="media-libs/libjpeg-turbo vpx? ( media-libs/libvpx ) openh264? ( media-libs/openh264 ) pulseaudio? ( media-sound/pulseaudio )"
RDEPEND="${DEPEND}"

src_prepare() {
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DBUILD_WITH_VPX=$(usex vpx)
-DBUILD_WITH_H264=$(usex openh264)
-DBUILD_RECORDER_WITH_SOUND=$(usex pulseaudio)
-DCMAKE_INSTALL_PREFIX=${EPREFIX}/usr
-DCMAKE_BUILD_TYPE=Release
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
}

0 comments on commit 49c50fd

Please sign in to comment.