Skip to content

Commit

Permalink
sys-cluster/spark-bin: new package.
Browse files Browse the repository at this point in the history
Apache Spark is a unified analytics engine for large-scale data
processing.

Closes: https://bugs.gentoo.org/523412
Signed-off-by: Patrice Clement <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
monsieurp committed Nov 5, 2018
1 parent dd20da9 commit 4ba0088
Show file tree
Hide file tree
Showing 4 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/spark-bin/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST spark-bin-2.3.1.tgz 225883783 BLAKE2B d89e83a54aaabd39c5fa0d9c51a1bb5635f60ded4869672a387d13d87fffbb48385d4fbf67b55a96e709f27348f73a089624a0563c98eaba31f93d74bf4548ee SHA512 dc3a97f3d99791d363e4f70a622b84d6e313bd852f6fdbc777d31eab44cbc112ceeaa20f7bf835492fb654f48ae57e9969f93d3b0e6ec92076d1c5e1b40b4696
1 change: 1 addition & 0 deletions sys-cluster/spark-bin/files/99spark
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
SPARK_HOME=/usr/lib/spark
16 changes: 16 additions & 0 deletions sys-cluster/spark-bin/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Java Team</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Alec Ten Harmsel</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
60 changes: 60 additions & 0 deletions sys-cluster/spark-bin/spark-bin-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit java-pkg-2

DESCRIPTION="Lightning-fast unified analytics engine"
HOMEPAGE="https://spark.apache.org"
SRC_URI="mirror://apache/spark/spark-${PV}/spark-${PV}-bin-hadoop2.7.tgz -> ${P}.tgz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
>=virtual/jre-1.8"

DEPEND="
>=virtual/jdk-1.8"

S="${WORKDIR}/spark-${PV}-bin-hadoop2.7"

DOCS=( LICENSE NOTICE README.md RELEASE )

# Nothing to compile here.
src_compile() { :; }

src_install() {
dodir usr/lib/spark
into usr/lib/spark

dobin bin/beeline \
bin/find-spark-home \
bin/pyspark \
bin/spark-class \
bin/spark-shell \
bin/spark-sql \
bin/spark-submit

insinto usr/lib/spark/bin
doins bin/load-spark-env.sh

insinto usr/lib/spark
doins -r conf
doins -r jars
doins -r python
doins -r sbin
doins -r yarn

dosym "${ED%/}"/usr/lib/spark/bin/beeline /usr/bin/beeline
dosym "${ED%/}"/usr/lib/spark/bin/pyspark /usr/bin/pyspark
dosym "${ED%/}"/usr/lib/spark/bin/pyspark /usr/bin/find-spark-home
dosym "${ED%/}"/usr/lib/spark/bin/spark-class /usr/bin/spark-class
dosym "${ED%/}"/usr/lib/spark/bin/spark-shell /usr/bin/spark-shell
dosym "${ED%/}"/usr/lib/spark/bin/spark-sql /usr/bin/spark-sql
dosym "${ED%/}"/usr/lib/spark/bin/spark-submit /usr/bin/spark-submit

doenvd "${FILESDIR}"/99spark
}

0 comments on commit 4ba0088

Please sign in to comment.