Skip to content

Commit

Permalink
dev-db/etcd: Version bump to 3.4.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Manuel Rüger <[email protected]>
  • Loading branch information
mrueg committed Sep 18, 2019
1 parent d5b56a4 commit 4bcc51a
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/etcd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST etcd-3.3.15.tar.gz 6271373 BLAKE2B 85786a2a4acaf144f80461a56775b8c91164e8f0c0034ef0741d98383ac400720ca69b855588a076dc174364330c0e12df73a36570983138e33a32cdbe69e22f SHA512 9fbc02c4aacb000335d558e9c5d4df672194d1b1b8511918efa35a6123bcd7f1a06ecc527f7ff01af7c7f0e818b4809918e640fd596ec51898bf511849f0a2c5
DIST etcd-3.4.0.tar.gz 8931860 BLAKE2B abeb78866b751a3a124f1aaba2b6709402a51d0c5f36a45c8386816e4059172206c7e3420865209a53cecf7452a8c8b510a6fd50b5c7a9fefaac577e5d3c4413 SHA512 8e130cc76a2284c98bb72e3832e10e25e45c6fbaa5da7c6a7a2dd14a069d4fea7659b13c1450b87b869e5936bdad47606d0c65292febb7257369531ff2658674
DIST etcd-3.4.1.tar.gz 8931994 BLAKE2B 4cfb8a87082be3323b9adb4290c91c4419b8c8d9b343196af07424f126afda4e702da7fed578d8fcd04d1c2c2e34524fb341734afc9c41d5e43ba103c865b262 SHA512 c5c0cd25ae12e02c162490d46ab726b4a1ab5a027435a884cf61b995d5dc290d58534ec271ed41efd7dd3a30b0bd040f74081d943e32928cce16e56484e3bfc5
81 changes: 81 additions & 0 deletions dev-db/etcd/etcd-3.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit user systemd golang-vcs-snapshot

KEYWORDS="~amd64"
EGO_PN="go.etcd.io/etcd"
GIT_COMMIT="a14579f"
MY_PV="${PV/_rc/-rc.}"
DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
HOMEPAGE="https://github.com/etcd-io/etcd"
SRC_URI="${HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="doc +server"
DEPEND=">=dev-lang/go-1.12:="
RDEPEND="!dev-db/etcdctl"

src_prepare() {
default
sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
-i "${S}"/src/${EGO_PN}/build || die
sed -e 's:\(for p in \)shellcheck :\1 :' \
-e 's:^ gofmt \\$:\\:' \
-e 's:^ govet \\$:\\:' \
-i "${S}"/src/${EGO_PN}/test || die
# missing ... in args forwarded to print-like function
sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
-i "${S}"/src/${EGO_PN}/raft/logger.go || die

# Avoid network-sandbox violations since go-1.13
rm src/${EGO_PN}/go.mod || die
}

pkg_setup() {
if use server; then
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
fi
}

src_compile() {
export -n GOCACHE XDG_CACHE_HOME #651934
export GOPATH=${S}
pushd src/${EGO_PN} || die
GO_BUILD_FLAGS=-v ./build || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin bin/etcdctl
use doc && dodoc -r Documentation
if use server; then
insinto /etc/${PN}
doins "${FILESDIR}/${PN}.conf"
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotated" "${PN}"
keepdir /var/lib/${PN}
fowners ${PN}:${PN} /var/lib/${PN}
fperms 0700 /var/lib/${PN}
keepdir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
fperms 755 /var/log/${PN}
fi
popd || die
}

src_test() {
pushd src/${EGO_PN} || die
GO111MODULES=off ./test || die
popd || die
}

0 comments on commit 4bcc51a

Please sign in to comment.