Skip to content

Commit

Permalink
dev-python/apsw: add 3.35.4_p1, bump to python 3.10
Browse files Browse the repository at this point in the history
fix direct CC call
passes tests

Closes: https://bugs.gentoo.org/704606
Closes: https://bugs.gentoo.org/723726
Signed-off-by: Zamarin Arthur <[email protected]>
Closes: gentoo#20936
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
arthurzam authored and mgorny committed May 30, 2021
1 parent 003d0ff commit 4bd082d
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/apsw/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST apsw-3.32.2_p1.zip 679785 BLAKE2B fb58a60f95a677a805b0347a0d8876e49c657092deeadb60a057f4afc62031313faf5a86b600d1d306e42f305c9af599d2439a7051e400cbba2d9185c213d5d1 SHA512 718de699c43eec139747f63c3c26da206aa20f104ec1c478009d29cedff7a432138726131b2458ecd3a67675254af77e94e50e8e96a208600fe2a94aa9d924c7
DIST apsw-3.35.4_p1.zip 685034 BLAKE2B 5845e5fcb286c587367955c33fbee9aa4b0687af666f1d50f35f5dec8e756a0fbcf0fdbd120dd3c7a78df1f05d8eae5a973a8a71fc8a6f4271fff7d83b399013 SHA512 f420560e5821bd6305705ee6c14174f1770f4811edcfe152cb1f2ceae4295f13c82552386a7ef42c5ce88165e88bd2080b4dc2809484598522914d99f2469135
46 changes: 46 additions & 0 deletions dev-python/apsw/apsw-3.35.4_p1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..10} )

inherit distutils-r1

MY_PV=${PV/_p/-r}
MY_P=${PN}-${MY_PV}

DESCRIPTION="APSW - Another Python SQLite Wrapper"
HOMEPAGE="https://github.com/rogerbinns/apsw/"
SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
S="${WORKDIR}/${MY_P}"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
IUSE="doc"

RDEPEND=">=dev-db/sqlite-${PV%_p*}"
DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"

PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )

python_prepare_all() {
sed -e 's/"gcc/os.environ.get("CC", "gcc") + "/' -i setup.py || die
distutils-r1_python_prepare_all
}

python_compile() {
distutils-r1_python_compile --enable=load_extension
}

python_test() {
esetup.py build_test_extension
"${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( doc/. )
distutils-r1_python_install_all
}

0 comments on commit 4bd082d

Please sign in to comment.