Skip to content

Commit

Permalink
app-shells/bash: Fixed parallel make issue
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.11, Repoman-3.0.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 7, 2020
1 parent b254a1f commit 4c2ebbf
Show file tree
Hide file tree
Showing 2 changed files with 16 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/bash/bash-5.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -103,6 +103,7 @@ src_prepare() {
touch -r . doc/* || die

eapply -p0 "${PATCHES[@]}"
eapply "${FILESDIR}/${PN}-5.1-parallel_make.patch"
eapply_user
}

Expand Down
15 changes: 15 additions & 0 deletions app-shells/bash/files/bash-5.1-parallel_make.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
bashline.c:65:10: fatal error: builtins/builtext.h: No such file or directory
65 | #include "builtins/builtext.h" /* for read_builtin */
| ^~~~~~~~~~~~~~~~~~~~~

--- bash-5.1/Makefile.in
+++ bash-5.1/Makefile.in
@@ -584,6 +584,8 @@
ls -l $(Program)
-$(SIZE) $(Program)

+$(CSOURCES): $(DEFDIR)/builtext.h
+
.build: $(SOURCES) config.h Makefile version.h $(VERSPROG)
@echo
@echo " ***********************************************************"

0 comments on commit 4c2ebbf

Please sign in to comment.