Skip to content

Commit

Permalink
app-emulation/crossover: Bump to 15.2.0
Browse files Browse the repository at this point in the history
Tested by exploring Crossover GUI and running Microsoft Word 2007. I
made a cursory effort to verify dependencies were up to date was made
and no changes were detected.

Package-Manager: portage-2.2.26
Reported-by: Emile de Weerd <[email protected]>
Signed-off-by: Richard Yao <[email protected]>
  • Loading branch information
ryao committed Sep 10, 2016
1 parent a132126 commit 4c93afc
Show file tree
Hide file tree
Showing 2 changed files with 148 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/crossover-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -11,3 +11,4 @@ DIST install-crossover-14.1.4.bin 68463678 SHA256 9e51823fca911916755b1edca8673c
DIST install-crossover-15.0.0.bin 80995834 SHA256 ac538e5568674e23f515b6725bb4cb8b17c516bc910c875d3ac7e45d69f7aff4 SHA512 597262b760c7cfc3c42cdb0b846802c6c47d4fcd5af06b53d0c63c80e4890e14af8ff0eaaac74a08f4f5d55e166a480d199b185efe685f7c42abca3d62fc2a0d WHIRLPOOL 18f5eb531ad32d27e4e2bea1f205593906ab0bcbc022f0963fd237101b26cb796f7f771ab5b7d57b126aea93627390fc55075611551109ad1ad98769a2711951
DIST install-crossover-15.0.1.bin 81027541 SHA256 ccb222775032711e6d7f3ca5994ebc51cb168cdb9e2599d186b3fb1336ac20fb SHA512 a35188ccebeee8d456e73fdcbb8e8d4f0aff41bb89d92767d2e2e78e7cb25c8e48a150393c1c9abeb9760fbc873314e301c0a364ba27acfe08e0980bb5eedb03 WHIRLPOOL 32396d7be78b6ca975d0eadb753f00c060f731eefee00bd4fbefcf4f96488104f9396632648a14af52976b75bd924325b68c3e7d79da6676bba5207aac5fd045
DIST install-crossover-15.1.0.bin 80623685 SHA256 def2d9f2bf59ba8779d15f6a63e8e58e60c8e25ffddeeb9446eccf5af72c16f9 SHA512 177e70baff3d99e808834c8e6f626f09d9c262babd6d5a3b51ea79a5a68a157cdfd4fd60ad6939d110f2300670e4973d9fd43a3a132ff9a2367dedb782e5c05c WHIRLPOOL 9a6655d0d3885d36613d0dc07ceaf02f2ee36481492787ca5e4fd59c657026dd62dbc56a09fac9ba1caa40d873e7ecd156c4d5ec22cc9185e242a099a2f4f3c7
DIST install-crossover-15.2.0.bin 80734561 SHA256 5a677c160afcfb88f1f24ad241a013bf4da430f1d1e6a109965aded298fa52fe SHA512 9633e29b26f8fa99d1c34347b8e1f2e89b84370994a1ab3bba7061b75224f3a907d1c364207312dde1995e5a59180f8699558a96a4c99b157257ab9c21013b2e WHIRLPOOL 0678e8794f31df994b5f02795f07dbf115dc8639deb04ac15f370a107fcccca5707101b6f68ec252ff248f0eaba0139d323ec2033f03880a602b3537b0fd58ae
147 changes: 147 additions & 0 deletions app-emulation/crossover-bin/crossover-bin-15.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,147 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit python-single-r1 unpacker

DESCRIPTION="Commercial version of app-emulation/wine with paid support."
HOMEPAGE="http://www.codeweavers.com/products/crossover/"
SRC_URI="https://media.codeweavers.com/pub/crossover/cxlinux/demo/install-crossover-${PV}.bin"

LICENSE="CROSSOVER-3"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opengl +png +scanner +ssl +v4l"
RESTRICT="bindist test"
QA_FLAGS_IGNORED="opt/cxoffice/.*"
QA_PRESTRIPPED="opt/cxoffice/lib/.*
opt/cxoffice/bin/cxburner
opt/cxoffice/bin/cxntlm_auth
opt/cxoffice/bin/wineserver
opt/cxoffice/bin/unrar
opt/cxoffice/bin/wine-preloader
opt/cxoffice/bin/cxdiag
opt/cxoffice/bin/cxgettext
opt/cxoffice/bin/wineloader
"
S="${WORKDIR}"

DEPEND="dev-lang/perl
app-arch/unzip
${PYTHON_DEPS}"

RDEPEND="${DEPEND}
!prefix? ( sys-libs/glibc )
>=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-util/desktop-file-utils
!app-emulation/crossover-office-pro-bin
!app-emulation/crossover-office-bin
capi? ( net-dialup/capi4k-utils )
cups? ( net-print/cups[abi_x86_32(-)] )
gsm? ( media-sound/gsm[abi_x86_32(-)] )
jpeg? ( virtual/jpeg[abi_x86_32(-)] )
lcms? ( media-libs/lcms:2 )
ldap? ( net-nds/openldap[abi_x86_32(-)] )
gphoto2? ( media-libs/libgphoto2[abi_x86_32(-)] )
mp3? ( >=media-sound/mpg123-1.5.0[abi_x86_32(-)] )
nls? ( sys-devel/gettext[abi_x86_32(-)] )
openal? ( media-libs/openal[abi_x86_32(-)] )
opengl? (
virtual/glu[abi_x86_32(-)]
virtual/opengl[abi_x86_32(-)]
)
png? ( media-libs/libpng:0[abi_x86_32(-)] )
scanner? ( media-gfx/sane-backends[abi_x86_32(-)] )
ssl? ( dev-libs/openssl:0[abi_x86_32(-)] )
v4l? ( media-libs/libv4l[abi_x86_32(-)] )
media-libs/alsa-lib[abi_x86_32(-)]
>=media-libs/freetype-2.0.0[abi_x86_32(-)]
media-libs/mesa[abi_x86_32(-)]
sys-apps/util-linux[abi_x86_32(-)]
sys-libs/zlib[abi_x86_32(-)]
x11-libs/libICE[abi_x86_32(-)]
x11-libs/libSM[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
x11-libs/libXau[abi_x86_32(-)]
x11-libs/libXdmcp[abi_x86_32(-)]
x11-libs/libXext[abi_x86_32(-)]
x11-libs/libXi[abi_x86_32(-)]
x11-libs/libXrandr[abi_x86_32(-)]
x11-libs/libXxf86vm[abi_x86_32(-)]
x11-libs/libxcb[abi_x86_32(-)]"

pkg_nofetch() {
einfo "Please visit ${HOMEPAGE}"
einfo "and place ${A} in ${DISTDIR}"
}

src_unpack() {
# self unpacking zip archive; unzip warns about the exe stuff
unpack_zip ${A}
}

src_prepare() {
python_fix_shebang .

sed -i \
-e "s:xdg_install_icons(:&\"${ED}\".:" \
-e "s:\"\(.*\)/applications:\"${ED}\1/applications:" \
-e "s:\"\(.*\)/desktop-directories:\"${ED}\1/desktop-directories:" \
"${S}/lib/perl/CXMenuXDG.pm"

# Remove unnecessary files
rm -r license.txt guis/ || die "Could not remove files"
use doc || rm -r doc/ || die "Could not remove files"
}

src_install() {
# Install crossover symlink, bug #476314
dosym /opt/cxoffice/bin/crossover /opt/bin/crossover

# Install documentation
dodoc README changelog.txt
rm README changelog.txt || die "Could not remove README and changelog.txt"

# Install files
dodir /opt/cxoffice
#cp -r ./* "${ED}opt/cxoffice" \
find . | cpio -dumpl "${ED}/opt/cxoffice" 2>/dev/null \
|| die "Could not install into ${ED}opt/cxoffice"

# Install configuration file
insinto /opt/cxoffice/etc
doins share/crossover/data/cxoffice.conf

# Install menus
# XXX: locate_gui.sh automatically detects *-application-merged directories
# This means what we install will vary depending on the contents of
# /etc/xdg, which is a QA violation. It is not clear how to resolve this.
XDG_DATA_DIRS="/usr/share" XDG_CONFIG_HOME="/etc/xdg" \
"${ED}opt/cxoffice/bin/cxmenu" --destdir="${ED}" --crossover --install \
|| die "Could not install menus"

rm "${ED}usr/share/applications/"*"Uninstall CrossOver Linux.desktop" \
"${ED}opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/Uninstall CrossOver Linux.desktop" \
|| die "Could not remove uninstall menus"
sed -i \
-e "s:\"${ED}\".::" \
-e "s:${ED}::" \
"${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm" \
|| die "Could not fix paths in ${ED}/opt/cxoffice/lib/perl/CXMenuXDG.pm"
sed -i -e "s:${ED}:/:" \
"${ED}/opt/cxoffice/support/desktopdata/cxoffice-0/cxmenu/Launchers/StartMenu/"*.desktop \
"${ED}usr/share/applications/"*"CrossOver.desktop" \
|| die "Could not fix paths of *.desktop files"
}

pkg_postinst() {
einfo "${P} is open source software with the exception of the GUI."
einfo "Source code can be obtained from:"
einfo
einfo "https://media.codeweavers.com/pub/crossover/source/crossover-sources-${PV}.tar.gz"
}

0 comments on commit 4c93afc

Please sign in to comment.