Skip to content

Commit

Permalink
mate-extra/mate-power-manager: Bump to 1.22.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <[email protected]>
  • Loading branch information
NP-Hardass authored and gktrk committed May 12, 2019
1 parent bc9d925 commit 4ce0a54
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-power-manager/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mate-power-manager-1.22.0.tar.xz 3182040 BLAKE2B 3635001cab5551a29ecf57ebfd84cb6f3dff9f3e16cefdbc7811c1ce9d140e543f6054925b460714ebd4aa8749e39326663866535394664b5ec2f0e94d92337e SHA512 d36ec8d328e00ccc14b26c36ded74f20ea80578870541899560c6a744018e5e91b08ec9b4d517548404e82da6f1868ed1f2fcc0aada1223f98e68dd6e6009503
DIST mate-power-manager-1.22.1.tar.xz 3188048 BLAKE2B af32a18e2561cc9689382ff9a94382180a5d2dc6ade34a6dc400a7b65730a6c26c6f32b72b6ec973210ac3baf4e8b6c54e489230e64b877cee4ffbbf1a195d28 SHA512 8eabd7f8171f0a6be610c849fad8346bb30ca2c69208e2e117f436daaa5ada3bf0fef479dc017f32f56ec6bd52a7ff7ff69d18baf01b402c5fa2747245261a81
72 changes: 72 additions & 0 deletions mate-extra/mate-power-manager/mate-power-manager-1.22.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

DESCRIPTION="A session daemon for MATE that makes it easy to manage your laptop or desktop"

LICENSE="GPL-2"
SLOT="0"
IUSE="+applet elogind gnome-keyring policykit systemd test"

REQUIRED_USE="?? ( elogind systemd )"

# Interactive testsuite.
RESTRICT="test"

COMMON_DEPEND="
>=dev-libs/dbus-glib-0.70
>=dev-libs/glib-2.50:2
>=media-libs/libcanberra-0.10:0[gtk3]
>=sys-apps/dbus-1
>=x11-apps/xrandr-1.3
>=x11-libs/cairo-1
>=x11-libs/gdk-pixbuf-2.11:2
>=x11-libs/gtk+-3.22:3
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrandr
>=x11-libs/libnotify-0.7:0
x11-libs/pango
applet? ( >=mate-base/mate-panel-1.17.0 )
gnome-keyring? ( >=gnome-base/libgnome-keyring-3 )
>=sys-power/upower-0.9.23:="

RDEPEND="${COMMON_DEPEND}
policykit? ( >=mate-extra/mate-polkit-1.6 )
systemd? ( sys-apps/systemd )
!systemd? (
elogind? ( sys-auth/elogind )
!elogind? ( >=sys-auth/consolekit-0.9.2 )
)"

DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.3
app-text/rarian
>=app-text/scrollkeeper-dtd-1:1.0
app-text/yelp-tools
dev-util/glib-utils
>=dev-util/intltool-0.50.1
sys-devel/gettext
virtual/pkgconfig
x11-base/xorg-proto"

src_configure() {
mate_src_configure \
--enable-compile-warnings=minimum \
$(use_with gnome-keyring keyring) \
$(use_enable applet applets) \
$(use_enable test tests)
}

src_test() {
unset DBUS_SESSION_BUS_ADDRESS

dbus-launch Xemake check || die "Test phase failed"
}

0 comments on commit 4ce0a54

Please sign in to comment.