Skip to content

Commit

Permalink
dev-python/paramiko: version bump to 2.2.1
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Aug 23, 2017
1 parent e425be0 commit 4cf03b6
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/paramiko/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST paramiko-1.16.0.tar.gz 1335094 SHA256 3297ebd3cd072f573772f7c7426939a443c62c458d54bb632ff30fd6ecf96892 SHA512 d75ed591c12898bab7d3e64b7281c9054ad49d00b6dba9e51826cca43ce30ae7c089ead0c3396f7542c2635183637e00a16f0b3d57360c0f65ec93d081489962 WHIRLPOOL 10053403a526e11d2e300cfccb8bb95889ee4424621853f8b20f42257c71fdb01aba6358c3fd9dd3ede2aa8d7291affac56582abbb3d9888dc1c217d3757c3f3
DIST paramiko-2.1.2.tar.gz 1196746 SHA256 5fae49bed35e2e3d45c4f7b0db2d38b9ca626312d91119b3991d0ecf8125e310 SHA512 465c5381b1b0a472d2ad8e690f0916a5f51713880486c7b94cadcf85ea0a52569e18337ccfee5440869e4a0c76bd2b1bc15c414128c07326b40ecd36ea021466 WHIRLPOOL 39014f4ab316ccf13ce336a594befd00c68dd3eb371f9e29592ec32ee1afcc91ae9307b2c9ae4227569fbc5d5d2c639532cce4552780d4e35743cd5c834a28a3
DIST paramiko-2.2.1.tar.gz 1205818 SHA256 ff94ae65379914ec3c960de731381f49092057b6dd1d24d18842ead5a2eb2277 SHA512 6aa2cce301f32c15d66e2137bc8a5c10ea4a667c599b24047a1e176b10636fe3abd28c7b2974befdde432a86c924acceace056c0572ea3006d3e4a8160b725c3 WHIRLPOOL 90f7d92c2d19343ab4f1ce78284458892af332197192f9368d862aa8d759fdbf37faf14c83f5ffacad4b7228be697bf011bf11e23800d49c5b58eaf149d3e9ff
45 changes: 45 additions & 0 deletions dev-python/paramiko/paramiko-2.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="SSH2 protocol library"
HOMEPAGE="http://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.python.org/pypi/paramiko/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"

RDEPEND="
>=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.1[${PYTHON_USEDEP}]
>=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"

# Required for testsuite
DISTUTILS_IN_SOURCE_BUILD=1

python_test() {
"${PYTHON}" test.py --verbose || die "Tests fail with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/. )

distutils-r1_python_install_all

if use examples; then
insinto /usr/share/doc/${PF}/examples
doins demos/*
fi
}

0 comments on commit 4cf03b6

Please sign in to comment.