forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-haskell/parser-combinators: Initial version
Package-Manager: Portage-2.3.40, Repoman-2.3.9
- Loading branch information
Showing
4 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,2 @@ | ||
DIST parser-combinators-0.4.0.tar.gz 9130 BLAKE2B 368482bd968a4476366ac04162efe1d8ac502dbb964b21e4090bf48ee9f3e81879bce69a0cb8e72d3b51b4f278be23c3c6bb4f4fd434938682c680214b0a95dd SHA512 9748a8a23bef1cb386970722e148a4cc4e36e8f4100ac34794e2a2223b4bfe0f1e6e0f58d82b500e535cc42a0066be0c5bb5676892e4b607d8d6eac4c4f93a28 | ||
DIST parser-combinators-1.0.0.tar.gz 10349 BLAKE2B c8b21ab8c1afd8fdc931f60258245596a70adb404366f5926743b61b6c7b802558436e7869d012dabaaa8d36097028269cec3c99f647958d0b15d14402c05c6b SHA512 308b38faca865801c2356b9eb0128824956f00a31d98de075166018b34d53a04bad0dc7f1afabafa9946b307ef3fb77df303db78ac7bd6ff476c9b96a3020e9c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Manuel Rüger</name> | ||
</maintainer> | ||
<longdescription> | ||
Lightweight package providing commonly useful parser combinators. | ||
</longdescription> | ||
</pkgmetadata> |
31 changes: 31 additions & 0 deletions
31
dev-haskell/parser-combinators/parser-combinators-0.4.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
# ebuild generated by hackport 0.5.5 | ||
#hackport: flags: -dev | ||
|
||
CABAL_FEATURES="lib profile haddock hoogle hscolour" | ||
inherit haskell-cabal | ||
|
||
DESCRIPTION="Lightweight package providing commonly useful parser combinators" | ||
HOMEPAGE="https://github.com/mrkkrp/parser-combinators" | ||
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?] | ||
>=dev-lang/ghc-7.4.1:= | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-haskell/cabal-1.18 | ||
" | ||
|
||
src_configure() { | ||
haskell-cabal_src_configure \ | ||
--flag=-dev | ||
} |
31 changes: 31 additions & 0 deletions
31
dev-haskell/parser-combinators/parser-combinators-1.0.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
# ebuild generated by hackport 0.5.5 | ||
#hackport: flags: -dev | ||
|
||
CABAL_FEATURES="lib profile haddock hoogle hscolour" | ||
inherit haskell-cabal | ||
|
||
DESCRIPTION="Lightweight package providing commonly useful parser combinators" | ||
HOMEPAGE="https://github.com/mrkkrp/parser-combinators" | ||
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?] | ||
>=dev-lang/ghc-7.10.1:= | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-haskell/cabal-1.22.2.0 | ||
" | ||
|
||
src_configure() { | ||
haskell-cabal_src_configure \ | ||
--flag=-dev | ||
} |