Skip to content

Commit

Permalink
x11-libs/libqxt: Add gcc 6 patch
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Closes: gentoo#3102
  • Loading branch information
MJDSys authored and SoapGentoo committed Jan 4, 2017
1 parent 45b1d6b commit 4d32a23
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 1 deletion.
12 changes: 12 additions & 0 deletions x11-libs/libqxt/files/libqxt-gcc6-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -ru libqxt-libqxt-v0.6.2/src/core/qxtslotjob.cpp libqxt-libqxt-v0.6.2.new/src/core/qxtslotjob.cpp
--- libqxt-libqxt-v0.6.2/src/core/qxtslotjob.cpp 2011-11-24 17:10:32.000000000 -0500
+++ libqxt-libqxt-v0.6.2.new/src/core/qxtslotjob.cpp 2016-12-08 18:07:07.460538282 -0500
@@ -174,7 +174,7 @@

QVariant QxtFuture::delayedResult(int msec)
{
- if (!waiter->wait(msec, false))
+ if (!waiter->wait(msec, QEventLoop::AllEvents))
return QVariant();
return job->result();
}
3 changes: 2 additions & 1 deletion x11-libs/libqxt/libqxt-0.6.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -39,6 +39,7 @@ PATCHES=(
"${FILESDIR}/${PN}-invoke-prev-filter.patch" # bug 494448
"${FILESDIR}/${PN}-media-keys.patch" # bug 495984
"${FILESDIR}/${PN}-xrandr-missing-lib.patch"
"${FILESDIR}/${PN}-gcc6-fix.patch"
)

src_prepare() {
Expand Down

0 comments on commit 4d32a23

Please sign in to comment.