Skip to content

Commit

Permalink
dev-ml/ocaml-hashcons: initial import; ebuild by me
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Mar 14, 2016
1 parent 7791ecc commit 4dca7b9
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/ocaml-hashcons/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST ocaml-hashcons-1.0.tar.gz 19624 SHA256 b32d9f9fb933708e9ab51184bb9d6a1523cea0d775a66c78161f30f5d7365cf3 SHA512 58afc7f65920f4e31884ecd7e7538dd86b2a7a7f4f449cae098d510ac0446fcb663bf29fbbb4a2c44ad0e6d93d83901d1af1b81d0f8770530a77e8d127dd5186 WHIRLPOOL 6e412db459c815469d02867c93a516d3b7633a16001688c6818c8a281fc64a5f819f5020adfff569ff37d23b005acfb48a1b2c94727d3121e4f40151c41c9812
8 changes: 8 additions & 0 deletions dev-ml/ocaml-hashcons/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo ML Project</name>
</maintainer>
</pkgmetadata>
38 changes: 38 additions & 0 deletions dev-ml/ocaml-hashcons/ocaml-hashcons-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit autotools findlib

DESCRIPTION="OCaml hash-consing library"
HOMEPAGE="https://github.com/backtracking/ocaml-hashcons"
SRC_URI="https://github.com/backtracking/ocaml-hashcons/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="+ocamlopt"

RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
DEPEND="${RDEPEND}"

src_prepare() {
eautoreconf
sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
}

src_compile() {
if use ocamlopt; then
emake opt byte
else
emake byte
fi
}

src_install() {
dodir "$(ocamlfind printconf destdir)/hashcons"
emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
dodoc README.md CHANGES
}

0 comments on commit 4dca7b9

Please sign in to comment.