Skip to content

Commit

Permalink
dev-qt/qt-docs: revision bump to remove colliding files
Browse files Browse the repository at this point in the history
Gentoo-bug: 597026

Package-Manager: portage-2.3.2
  • Loading branch information
kensington committed Nov 23, 2016
1 parent 4090447 commit 4f3eaa4
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions dev-qt/qt-docs/qt-docs-5.6.2_p0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit versionator

MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
MY_P=${PV/_p/-}qt-everywhere-documentation-${PV%%_p*}

DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
HOMEPAGE="https://www.qt.io/"
SRC_URI="https://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${MY_P}.7z"

LICENSE="FDL-1.3"
SLOT="5"
KEYWORDS="~amd64 ~x86"

DEPEND="app-arch/p7zip"

S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)

src_install() {
# ${PV} instead of ${PF} is intentional
local dest=/usr/share/doc/qt-${PV%%_p*}
insinto "${dest}"
doins -r *
docompress -x "${dest}"

# these files are not shipped in any other version of qt-docs and collide with qtcore
# bug 597026
rm -r "${ED}"/usr/share/doc/qt-5.6.2/global
}

0 comments on commit 4f3eaa4

Please sign in to comment.