Skip to content

Commit

Permalink
media-libs/harfbuzz: Bump to version 2.6.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jun 4, 2020
1 parent c4ba7c2 commit 4f533b2
Show file tree
Hide file tree
Showing 2 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/harfbuzz/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST harfbuzz-2.6.4.tar.xz 5967468 BLAKE2B 24d215324a408a724f47a901c4a56605144d15373518bd52643ece83705d0c63582a80635ecef6a6d8d2f5f39c750076d553fb39aaa8c0dd41702ee910c32f24 SHA512 d8664bb64fda11ff7646693070637e3827f8b3d1de50e11ecf108ce4d19c878b26b2ba4cff278da6e6cc0cb431e1630d9eaa7c32a9bebb9655a7aa8dabf7114f
DIST harfbuzz-2.6.5.tar.xz 8510596 BLAKE2B e495fbba7e0cb58918afeb6beb3ebcf936be896ca606cef27dcbfb9b5f10add144f7fcaa50dec35a9f909d7e87deebadb7c9e6bbbadcbd799effd96076786cde SHA512 ae66211f9b4233c1da4b22b703ab4912f684390294c5c88113e6c927d5aeda8960da3ff607a7c7be5968d9fbb5a95b1f6933070d0aab2aa442a3ec8a112cd16f
DIST harfbuzz-2.6.6.tar.xz 8530984 BLAKE2B 59ddbffdd6d7af44a1564079e8313cd24a5811cae2de46a632ebf7ec3e76b3c600d159b8be0e52cc1a776c9975955d0e888ce69c304467b3eaef41f09b2be493 SHA512 b0b6323b893a3540e36e2358cc7e7d27c98aa14f1debe65cd8eaf817a55752ea4f22369e37e195abefd03bbc787f178d1b64f167237683ac208b9a65b0ae09c8
DIST harfbuzz-2.6.7.tar.xz 9001936 BLAKE2B bd3a195506253a1446e877c35c067cc874826fc6fdae3bc3a9bfd2b7682ce12de7e6d7fd4ebe03b8178d8b678c06aa2d71715b27236347224a68e4d98a72039e SHA512 6fdd6e0952a73e1949349aa5416ef8fb3fc351b15c95be4fe1f341b111159fe58113b73a334db2697f4e3aaef5a761bd8f1d8964514406cad40f9862768d59de
116 changes: 116 additions & 0 deletions media-libs/harfbuzz/harfbuzz-2.6.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,116 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )

inherit autotools flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils

DESCRIPTION="An OpenType text shaping engine"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"

if [[ ${PV} = 9999 ]] ; then
EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
inherit git-r3
else
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

LICENSE="Old-MIT ISC icu"
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416

IUSE="+cairo debug +glib +graphite icu +introspection static-libs test +truetype"
RESTRICT="!test? ( test )"
REQUIRED_USE="introspection? ( glib )"

RDEPEND="
cairo? ( x11-libs/cairo:= )
glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.34:= )
truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
test? ( ${PYTHON_DEPS} )
"
BDEPEND="
dev-util/gtk-doc-am
virtual/pkgconfig
"
# eautoreconf requires gobject-introspection-common
# ragel needed if regenerating *.hh files from *.rl
if [[ ${PV} = 9999 ]] ; then
DEPEND+="
>=dev-libs/gobject-introspection-common-1.34
dev-util/ragel
"
fi

pkg_setup() {
use test && python-any-r1_pkg_setup
if ! use debug ; then
append-cppflags -DHB_NDEBUG
fi
}

src_prepare() {
default

xdg_environment_reset

if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
# on Darwin/Solaris we need to link with g++, like automake defaults
# to, but overridden by upstream because on Linux this is not
# necessary, bug #449126
sed -i \
-e 's/\<LINK\>/CXXLINK/' \
src/Makefile.am || die
sed -i \
-e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
src/Makefile.in || die
sed -i \
-e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
test/api/Makefile.in || die
fi

sed -i \
-e 's:tests/macos.tests::' \
test/shaping/data/in-house/Makefile.sources \
test/shaping/data/in-house/Makefile.in || die # bug 726120

eautoreconf
elibtoolize # for Solaris

# bug 618772
append-cxxflags -std=c++14
}

multilib_src_configure() {
# harfbuzz-gobject only used for instrospection, bug #535852
local myeconfargs=(
--without-coretext
--without-fontconfig #609300
--without-uniscribe
$(use_enable static-libs static)
$(multilib_native_use_with cairo)
$(use_with glib)
$(use_with introspection gobject)
$(use_with graphite graphite2)
$(use_with icu)
$(multilib_native_use_enable introspection)
$(use_with truetype freetype)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"

if multilib_is_native_abi; then
ln -s "${S}"/docs/html docs/html || die
fi
}

multilib_src_install_all() {
einstalldocs
find "${ED}" -type f -name "*.la" -delete || die
}

0 comments on commit 4f533b2

Please sign in to comment.