Skip to content

Commit

Permalink
app-misc/workrave: Force the use of gstreamer-1 instead of letting au…
Browse files Browse the repository at this point in the history
…tomagic switching (#563584 by Lucian Poston), don't enable introspection support automagically (#561124 by Toralf Förster), debug configure option is only playing with CFLAGS, stop relying on obsolete gnet lib as other distributions are doing for years.

Package-Manager: portage-2.2.23
  • Loading branch information
pacho2 committed Oct 24, 2015
1 parent 80a5c0d commit 4ff1769
Show file tree
Hide file tree
Showing 3 changed files with 126 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/workrave/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST v1_10_6.tar.gz 6444740 SHA256 f8699fbbfef7f3de2226f5f7dc4c74d98de3b59bfed4c6dac70bb231ec405760 SHA512 5c2a7dac1614751edf925eefa945e08e0b2fb318903b12fc8d4acde0b6027ecb534c90933da14796edc958f0d9a2f892815fddea9ab41ac921756fc5577acd8e WHIRLPOOL 91c47a66f0ab60f2560b103ef7ac6591088296b470d3403d6d9f511d44e361fc6841d9fda85d9c24d6c60595ea66b2a18ebb34c806d3ab4b465895a427a6d819
DIST workrave-1.10.1.tar.gz 6800197 SHA256 6ef89aebd278e27d3b73896485e7d8aaef415e7d18318d3bb7ba0d0507bd48de SHA512 4f721ebaceb43f542c25b0eb3fcd2e2d205290c982ddb57628c56bfed0c63fdde85adf304b4fdaf07908e31e8e31942ffdf17a9f1f0a3e62fec71aa5722d946a WHIRLPOOL f365ba528ef56cc6475dc7898b98d08532724a5cebab81e0a7b25534eaa78871a7ac2e7d7d016fd6812099031355d4950b7eecd671befa2127295cbc68dca498
DIST workrave-1.10.6.tar.gz 6444740 SHA256 f8699fbbfef7f3de2226f5f7dc4c74d98de3b59bfed4c6dac70bb231ec405760 SHA512 5c2a7dac1614751edf925eefa945e08e0b2fb318903b12fc8d4acde0b6027ecb534c90933da14796edc958f0d9a2f892815fddea9ab41ac921756fc5577acd8e WHIRLPOOL 91c47a66f0ab60f2560b103ef7ac6591088296b470d3403d6d9f511d44e361fc6841d9fda85d9c24d6c60595ea66b2a18ebb34c806d3ab4b465895a427a6d819
23 changes: 23 additions & 0 deletions app-misc/workrave/files/workrave-1.10.6-automagic-gstreamer.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
--- configure.ac.old 2015-10-24 10:11:47.469290574 +0200
+++ configure.ac 2015-10-24 10:14:35.918680898 +0200
@@ -884,20 +884,12 @@
if test "x$enable_gstreamer" != "xno";
then
PKG_CHECK_MODULES([GSTREAMER],
- [gstreamer-0.10],
- [config_gstreamer=yes
- AC_DEFINE(HAVE_GSTREAMER, 1, [Use GStreamer for playing sounds])], [ ])
-
- if test "x$config_gstreamer" != "xyes";
- then
- PKG_CHECK_MODULES([GSTREAMER],
[gstreamer-1.0],
[config_gstreamer=yes
AC_DEFINE(HAVE_GSTREAMER, 1, [Use GStreamer for playing sounds])],
[if test "x$enable_gstreamer" = "xyes"; then
AC_MSG_ERROR([GStreamer development headers not found.])
fi])
- fi
fi


102 changes: 102 additions & 0 deletions app-misc/workrave/workrave-1.10.6-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
GCONF_DEBUG="no" # --enable-debug only messes up with FLAGS
PYTHON_COMPAT=( python2_7 )

inherit autotools eutils gnome2 python-single-r1 versionator

DESCRIPTION="Helpful utility to attack Repetitive Strain Injury (RSI)"
HOMEPAGE="http://www.workrave.org/"
# SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
MY_PV=$(replace_all_version_separators '_')
SRC_URI="https://github.com/rcaelers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"

# dbus support looks to be used only for trying to use panel applets on gnome3!
IUSE="ayatana doc gnome gstreamer introspection mate nls pulseaudio test xfce"
REQUIRED_USE="ayatana? ( introspection )"

RDEPEND="
>=dev-libs/glib-2.28.0:2
>=x11-libs/gtk+-3.0:3[introspection?]
>=dev-cpp/gtkmm-3.0.0:3.0
>=dev-cpp/glibmm-2.28.0:2
>=dev-libs/libsigc++-2.2.4.2:2
ayatana? (
>=dev-libs/libdbusmenu-0.4[gtk3,introspection]
>=dev-libs/libindicator-0.4:3 )
gnome? ( >=gnome-base/gnome-shell-3.6.2 )
gstreamer? (
media-libs/gstreamer:1.0[introspection?]
media-libs/gst-plugins-base:1.0[introspection?] )
introspection? ( dev-libs/gobject-introspection:= )
mate? ( mate-base/mate-applets )
pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
xfce? (
>=x11-libs/gtk+-2.6.0:2[introspection?]
>=xfce-base/xfce4-panel-4.4 )
x11-libs/libXScrnSaver
x11-libs/libSM
x11-libs/libX11
x11-libs/libXtst
x11-libs/libXt
x11-libs/libXmu
"
# dbus? (
# >=sys-apps/dbus-1.2
# dev-libs/dbus-glib )

DEPEND="${RDEPEND}
>=dev-util/intltool-0.40.0
x11-proto/xproto
x11-proto/inputproto
x11-proto/recordproto
dev-python/cheetah
virtual/pkgconfig
doc? (
app-text/docbook-sgml-utils
app-text/xmlto )
nls? ( >=sys-devel/gettext-0.17 )
"

pkg_setup() {
python-single-r1_pkg_setup
}

src_prepare() {
# Fix gstreamer slot automagic dependency, bug #563584
# http://issues.workrave.org/show_bug.cgi?id=1179
epatch "${FILESDIR}"/${PN}-1.10.6-automagic-gstreamer.patch
eautoreconf
gnome2_src_prepare
}

src_configure() {
# gnet ("distribution") is dead for ages and other distributions stopped
# relying on it for such time too.
gnome2_src_configure \
--disable-dbus \
--disable-distribution \
--enable-exercises \
--disable-experimental \
--disable-gnome2 \
--disable-static \
--disable-xml \
$(use_enable ayatana indicator) \
$(use_enable doc manual) \
$(use_enable gnome gnome3) \
$(use_enable gstreamer) \
$(use_enable introspection) \
$(use_enable mate) \
$(use_enable nls) \
$(use_enable pulseaudio pulse) \
$(use_enable test tests) \
$(use_enable xfce)
}

0 comments on commit 4ff1769

Please sign in to comment.