Skip to content

Commit

Permalink
app-eselect/eselect-repository: Bump to v1
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Sep 22, 2017
1 parent 4df0a1d commit 5103c19
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-eselect/eselect-repository/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST eselect-repository-1.tar.gz 5378 SHA256 d73d4ab5fd525f3504814b25087a051bde1b358033f996e10eca3d5eeeeabf22 SHA512 7f985c3abe3fa02dfe44aade71583e7280c4757470fe8bf43de8fcc2403e8b924d9b0af104e926a2b3cd79a92b440570347db511767c908dda087ccc9f3aba6e WHIRLPOOL 8ad0d21452a0094007b795aa105312110404dca33ee8c8e3c189b08f9fbad7759c2f1fe6572839c06cb7bdbaa39740195d674e72dc72debf6f118570d40daec2
38 changes: 38 additions & 0 deletions app-eselect/eselect-repository/eselect-repository-1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{3_4,3_5,3_6} )
inherit python-single-r1

DESCRIPTION="Manage repos.conf via eselect"
HOMEPAGE="https://github.com/mgorny/eselect-repository"
SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="${PYTHON_DEPS}
app-admin/eselect
net-misc/wget"

src_compile() {
MAKEARGS=(
PREFIX="${EPREFIX}/usr"
SYSCONFDIR="${EPREFIX}/etc"
SHAREDSTATEDIR="${EPREFIX}/var"
ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
)

emake "${MAKEARGS[@]}"
python_fix_shebang eselect-repo-helper
}

src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
keepdir /var/db/repos
einstalldocs
}

0 comments on commit 5103c19

Please sign in to comment.