Skip to content

Commit

Permalink
games-misc/nyancat: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Version bump to 1.5.1

Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Oct 11, 2016
1 parent 9bfa126 commit 51116b3
Show file tree
Hide file tree
Showing 3 changed files with 69 additions and 0 deletions.
45 changes: 45 additions & 0 deletions games-misc/gtklife/gtklife-5.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="A Conway's Life simulator for Unix"
HOMEPAGE="http://ironphoenix.org/tril/gtklife/"
SRC_URI="http://ironphoenix.org/tril/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE=""

RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:2
x11-libs/libX11"
DEPEND="${RDEPEND}
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${P}-link.patch
)

src_configure() {
econf \
--with-gtk2 \
--with-docdir=/usr/share/doc/${PF}/html
}

src_install() {
dobin ${PN}

insinto /usr/share/${PN}
doins -r graphics patterns

newicon icon_48x48.png ${PN}.png
make_desktop_entry ${PN} GtkLife

dodoc -r doc/*
dodoc AUTHORS README NEWS
}
1 change: 1 addition & 0 deletions games-misc/nyancat/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nyancat-1.2.1.tar.gz 14109 SHA256 a5bfafb6ea69917071aa05f9a52db43e47e97272eb2f4c6c827630cddb015972 SHA512 882bdcfe702d4613484b293f767a2ed74da63f222071e59f56a4246f56947882540930bcb2deae22f6e3326064f1c6f0ff7eb78ac6d7aa08125ebe64ebdf16eb WHIRLPOOL 3c263a35cee24babac92b3ed6ec33a8a4324adcec3364ffef2d0a3ac01786689a9969a21fde3ce1d278f572cd204be336d32d2411168bf6ac46ae47de20a5204
DIST nyancat-1.5.1.tar.gz 15124 SHA256 c948c769d230b4e41385173540ae8ab1f36176de689b6e2d6ed3500e9179b50a SHA512 0a45bd0b1a9b9f85650a986c7f9f8120441f6b0bd346281fb44a5470382484738e660dffe17b95088332c50b6aed3feb4b2f949f15f37dd9c1b1885f345e157d WHIRLPOOL 79aa5ed1076f61e1689c0b9dbffda5091ee2fc21335dedd79108ea746d9763b35f1069af3961b04f091b344ef6521525e56f8cd3cbe6d6048611998df7cdaeac
23 changes: 23 additions & 0 deletions games-misc/nyancat/nyancat-1.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

DESCRIPTION="Nyan Cat Telnet Server"
HOMEPAGE="https://github.com/klange/nyancat"
SRC_URI="https://github.com/klange/nyancat/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

src_compile() {
emake LFLAGS="${LDFLAGS} ${CFLAGS}"
}

src_install() {
dobin src/${PN}
dodoc README.md
}

0 comments on commit 51116b3

Please sign in to comment.