Skip to content

Commit

Permalink
media-gfx/valentina: version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Miroslav Šulc <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
fordfrog committed Oct 23, 2018
1 parent d4396f9 commit 5165dd3
Show file tree
Hide file tree
Showing 2 changed files with 126 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/valentina/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST valentina-0.5.0.zip 37175844 BLAKE2B 73cfb434c87e7d59efa76c303f4cc13dd9df08b9d5f61becd03943b78ce68e8735d192f2f2d5d5dfe25cda19ba998b0ea4a73bc3d0845bd4a065f7c5b4e66098 SHA512 3e69f965de1f8179850a8c6a5a0d3b5e87384158191b9c4a3647a5421d1efe567e98298bd8f47a8288eac358520469ae7979a4a61df64ccfbeb1a36fb231efcf
DIST valentina-0.6.0.zip 38305855 BLAKE2B 82733e97cd2ab1c2e0edddc05de228c040c43bd6a21b874b30554c526123ebd26d70f9fb8bb7556062f7df7b8d8f38c370d0f9ccd3d38100dacf841a68d4d1e6 SHA512 3bcc943c155b1b848c5328b53c8148448ede8fd057c8a50570045f61519bbeaaf0831f4a16127a24537feacb5251236c3bdc96e02788729635f4ec072686ca16
DIST valentina-0.6.1.zip 38326440 BLAKE2B 33d9163058b890254120bb0849972941f36526c71ed0acd8df82867a0116a35be4818c31c3ebb8a7322cf53bca4f9e77b2de10ea0df51c46b764f8f9e7abb8d2 SHA512 6511194c734a1b6cd8a1ed489213c288e90bd653dbd8373c4ee13be78e2ae4fe00a35e19a5ee074e868319ab1a13eb8baea35dedb7242b3888d03aa4b4dc69ce
DIST valentina-4798.patch 25302 BLAKE2B 153cc2ccc603703a520b5181e5192bac86410ab51eec305effe43463ce081dbbf3bb48eedb93e8ea5928f3f71351526a175c61a23a7005fda5bf4e14cc57403e SHA512 c3adbd2caa4cfb73960de850b29bee881fc408c9e4032e1fa2f29ba80b91abaa194738ff1cfb607657343990a166ad310387a66ceca546ffae0543d774bc53b4
DIST valentina-4802.patch 6733 BLAKE2B b7e30b77aab75b45e7bfd06165586f8356cfa438e0f5f5fb708d818f04fe9be7fdd025b8098cb5ca1f45cceef0671abf7014c112ab11da8e6c9c1a640e412ab8 SHA512 5628599c1dd208ba9ea8ea5e518bf6aed5ef11aa750670335478e5af49d6e9f235901c79d6483b1897f8288259fd06b463462eddcd062c4920ff251430998ff4
DIST valentina-5406.patch 596 BLAKE2B 34c5cf515555e455416500795c2afd96176b3ca3c2c3e278dbb6311e7cfb38bba6556126beef23d8b98ace76f0156250974d95310a6af046c0884580aa1d19d9 SHA512 f504ca766969703a20fc7c16652d4615722afda9156eb07c43845d1a6e9c7d08a2e8f07be7c71b4379326757f95e95e85858add2b1d13b0e4e5e8b1974ce18ae
125 changes: 125 additions & 0 deletions media-gfx/valentina/valentina-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,125 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit qmake-utils gnome2-utils xdg-utils

DESCRIPTION="Cloth patternmaking software"
HOMEPAGE="https://valentinaproject.bitbucket.io/"
SRC_URI="https://bitbucket.org/dismine/${PN}/get/v${PV}.zip -> ${P}.zip"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnome"

LANGS="cs de el en en es fi fr he id it nl pt-BR ro ru uk zh-CN"

for LANG in ${LANGS}; do
IUSE="${IUSE} l10n_${LANG}"
done

CDEPEND="
app-text/poppler
dev-qt/linguist:5
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5[ssl]
dev-qt/qtprintsupport:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
dev-qt/qtxmlpatterns:5"
RDEPEND="${CDEPEND}"
DEPEND="${CDEPEND}
app-arch/unzip"

S=${WORKDIR}/dismine-${PN}-b639b75d1688

src_configure() {
local locales=""
local locale

for LANG in ${LANGS}; do
if use l10n_${LANG}; then
case ${LANG} in
"cs")
locale="cs_CZ"
;;
"de")
locale="de_DE"
;;
"el")
locale="el_GR"
;;
"en")
locale="en_CA en_IN en_US"
;;
"es")
locale="es_ES"
;;
"fi")
locale="fi_FI"
;;
"fr")
locale="fr_FR"
;;
"he")
locale="he_IL"
;;
"id")
locale="id_ID"
;;
"it")
locale="it_IT"
;;
"nl")
locale="nl_NL"
;;
"pt-BR")
locale="pt_BR"
;;
"ro")
locale="ro_RO"
;;
"ru")
locale="ru_RU"
;;
"uk")
locale="uk_UA"
;;
"zh-CN")
locale="zh_CN"
;;
esac

locales="${locales} ${locale}"
fi
done

eqmake5 LOCALES="${locales}" "CONFIG+=noDebugSymbols no_ccache noRunPath noTests noWindowsInstaller" Valentina.pro -r
}

src_install() {
emake install INSTALL_ROOT="${D}"

dodoc AUTHORS.txt ChangeLog.txt README.txt

doman dist/debian/${PN}.1
doman dist/debian/tape.1

cp dist/debian/valentina.sharedmimeinfo dist/debian/${PN}.xml || die
insinto /usr/share/mime/packages
doins dist/debian/${PN}.xml
}

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update

if use gnome ; then
gnome2_icon_cache_update
fi
}

0 comments on commit 5165dd3

Please sign in to comment.