Skip to content

Commit

Permalink
mate-extra/mate-power-manager: Version bump (v1.22.0)
Browse files Browse the repository at this point in the history
Signed-off-by: Mikle Kolyada <[email protected]>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
  • Loading branch information
Zlogene committed Mar 17, 2019
1 parent 91b832a commit 517064a
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-power-manager/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mate-power-manager-1.18.1.tar.xz 3210144 BLAKE2B 7ab427acefd02b4aeea6fa2dd3052e2eaa9de3231ed9f8aa7b81af3a46fbf15da20925b568364ff802598738a7c3387d1b1fa620bef3ff2fd5522bb6247c2f3c SHA512 f4b42f66607e54020901f1f686cb018962c419294e50e0b37724bfddb462cf98a2e74e7ed980c3fe968873ca3848ff401839b39f53f1b40876773bfbf91b51c1
DIST mate-power-manager-1.22.0.tar.xz 3182040 BLAKE2B 3635001cab5551a29ecf57ebfd84cb6f3dff9f3e16cefdbc7811c1ce9d140e543f6054925b460714ebd4aa8749e39326663866535394664b5ec2f0e94d92337e SHA512 d36ec8d328e00ccc14b26c36ded74f20ea80578870541899560c6a744018e5e91b08ec9b4d517548404e82da6f1868ed1f2fcc0aada1223f98e68dd6e6009503
65 changes: 65 additions & 0 deletions mate-extra/mate-power-manager/mate-power-manager-1.22.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

DESCRIPTION="A session daemon for MATE that makes it easy to manage your laptop or desktop"
LICENSE="GPL-2"
SLOT="0"

IUSE="+applet gnome-keyring policykit systemd test"

# Interactive testsuite.
RESTRICT="test"

COMMON_DEPEND=">=dev-libs/dbus-glib-0.70
>=dev-libs/glib-2.50:2
>=media-libs/libcanberra-0.10:0[gtk3]
>=sys-apps/dbus-1
>=x11-apps/xrandr-1.3
>=x11-libs/cairo-1
>=x11-libs/gdk-pixbuf-2.11:2
>=x11-libs/gtk+-3.22:3
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrandr
>=x11-libs/libnotify-0.7:0
x11-libs/pango
applet? ( >=mate-base/mate-panel-1.17.0 )
gnome-keyring? ( >=gnome-base/libgnome-keyring-3 )
>=sys-power/upower-0.9.23:=
systemd? ( sys-apps/systemd )
!systemd? ( >=sys-auth/consolekit-0.9.2 )"

RDEPEND="${COMMON_DEPEND}
policykit? ( >=mate-extra/mate-polkit-1.6 )"

DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.3
app-text/rarian
>=app-text/scrollkeeper-dtd-1:1.0
app-text/yelp-tools
>=dev-util/intltool-0.50.1:*
x11-base/xorg-proto
sys-devel/gettext:*
virtual/pkgconfig:*"

src_configure() {
mate_src_configure \
--enable-compile-warnings=minimum \
$(use_with gnome-keyring keyring) \
$(use_enable applet applets) \
$(use_enable test tests)
}

src_test() {
unset DBUS_SESSION_BUS_ADDRESS

dbus-launch Xemake check || die "Test phase failed"
}

0 comments on commit 517064a

Please sign in to comment.