Skip to content

Commit

Permalink
net-analyzer/check_mk_agent: bump 1.2.8 to p27, add 1.4.0_p31
Browse files Browse the repository at this point in the history
Upstream has changed packaging to now include yet another layer of tarball,
so ebuilds now install check_mk_agent out of the full "Raw" OMD release.

Other than that, the only new thing is that the inventory plugin can be
auto-installed via the new 'inventory' use flag.

Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
axs-gentoo committed Aug 27, 2018
1 parent dfba252 commit 51d4359
Show file tree
Hide file tree
Showing 4 changed files with 85 additions and 29 deletions.
3 changes: 2 additions & 1 deletion net-analyzer/check_mk_agent/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST check_mk-1.2.8p16.tar.gz 16298683 BLAKE2B 5023719c3e2e56807900ccb204862eccb73706bb23dfa3dfb4f30cb6fa592828e2d81aef12dd5129b280c37ca8d700c982f3b29469fd5ec0328e91e414b8c624 SHA512 601c76b2b62de9176122c69b011b5f7ac6b71650d1b3e411c103f5e9c3e91256ce8d3db6fcd1edc2a11f86dcba4e8ea18ec5a1f9f3eae5b25a4bb3ba712341eb
DIST check-mk-raw-1.2.8p27.cre.tar.gz 150213236 BLAKE2B f239edee68fdfc32aba9af40dead69ecdcb699b437b3ec615a3bf84b5eaa3644203ba4afea3d24a16ae722fe05eebb2650af1846eded97e322d88f2d7f5d102d SHA512 781b3dad0e144dc23a0d6791fa90a8ee2652919f898fa275abf7760d137f18ebe037a7d5d8f17c437f99fb7d0b22e57fdb42749dd6c084c74c5e2ef404eb3c1f
DIST check-mk-raw-1.4.0p31.cre.tar.gz 314212612 BLAKE2B 07c9bda8524250f949a21204427d455ef0ac0a323fe38b66c7c4f03b50f7677099b5c24dae22f55fe1e1a2e475d541e1b643169a2368925e960ea514a03fd6b2 SHA512 b1dfe22e54a3d6f9c7f76b408adeb7ca46aa4b21d933149c1681bf87dae7af8f5bf645ba19b225f30b0057d8d075f657756019e3b908d3090e1d14451e7fcc0b
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -9,57 +9,36 @@ DESCRIPTION="Agent to report data to Check_MK for monitoring"
HOMEPAGE="http://mathias-kettner.de/check_mk.html"

MY_PV="${PV/_p/p}"
MY_P="check_mk-${MY_PV}"
MY_P="check-mk-raw-${MY_PV}.cre"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="apache_status logwatch mysql nfsexports oracle postgres smart +xinetd zypper"
IUSE="apache_status inventory logwatch mysql nfsexports oracle postgres smart +xinetd zypper"

RDEPEND="!!net-analyzer/check_mk
app-shells/bash:*
xinetd? ( || ( sys-apps/xinetd sys-apps/systemd ) )
"
DEPEND="${RDEPEND}"

SRC_URI="http://mathias-kettner.de/download/${MY_P}.tar.gz"
SRC_URI="http://mathias-kettner.de/support/${MY_PV}/${MY_P}.tar.gz"

src_unpack() {
# check_mk is a tarball containing tarballs
unpack ${A}
unpack "${WORKDIR}"/${MY_P}/packages/check_mk/check_mk-${MY_PV}.tar.gz
mkdir -p "${S}" || die
cd "${S}" || die
unpack "${WORKDIR}"/${MY_P}/agents.tar.gz
unpack "${WORKDIR}"/check_mk-${MY_PV}/agents.tar.gz
mkdir -p "${S}"/doc || die
cd "${S}"/doc || die
unpack "${WORKDIR}"/${MY_P}/doc.tar.gz
}

src_prepare() {
cat <<EOF >Makefile
all: waitmax
waitmax: waitmax.c
\$(CC) \$(CFLAGS) \$< -o \$@ \$(LDFLAGS)
EOF

if [[ -f waitmax ]]; then
rm waitmax || die "Couldn't delete precompiled waitmax file"
fi

default
}

src_compile() {
# compile waitmax
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
unpack "${WORKDIR}"/check_mk-${MY_PV}/doc.tar.gz
}

src_install() {
# Install agent related files
newbin check_mk_agent.linux check_mk_agent
dobin waitmax

keepdir /usr/lib/check_mk_agent/local
dodir /usr/lib/check_mk_agent/plugins
Expand All @@ -84,6 +63,7 @@ src_install() {

# Install any other useflag-enabled agent plugins
exeinto /usr/lib/check_mk_agent/plugins
use inventory && newexe plugins/mk_inventory.linux mk_inventory
use smart && doexe plugins/smart
use mysql && doexe plugins/mk_mysql
use postgres && doexe plugins/mk_postgres
Expand Down
74 changes: 74 additions & 0 deletions net-analyzer/check_mk_agent/check_mk_agent-1.4.0_p31.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit systemd

DESCRIPTION="Agent to report data to Check_MK for monitoring"
HOMEPAGE="http://mathias-kettner.de/check_mk.html"

MY_PV="${PV/_p/p}"
MY_P="check-mk-raw-${MY_PV}.cre"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="apache_status inventory logwatch mysql nfsexports oracle postgres smart +xinetd zypper"

RDEPEND="!!net-analyzer/check_mk
app-shells/bash:*
xinetd? ( || ( sys-apps/xinetd sys-apps/systemd ) )
"
DEPEND="${RDEPEND}"

SRC_URI="http://mathias-kettner.de/support/${MY_PV}/${MY_P}.tar.gz"

src_unpack() {
# check_mk is a tarball containing tarballs
unpack ${A}
unpack "${WORKDIR}"/${MY_P}/packages/check_mk/check_mk-${MY_PV}.tar.gz
mkdir -p "${S}" || die
cd "${S}" || die
unpack "${WORKDIR}"/check_mk-${MY_PV}/agents.tar.gz
mkdir -p "${S}"/doc || die
cd "${S}"/doc || die
unpack "${WORKDIR}"/check_mk-${MY_PV}/doc.tar.gz
}

src_install() {
# Install agent related files
newbin check_mk_agent.linux check_mk_agent

keepdir /usr/lib/check_mk_agent/local
dodir /usr/lib/check_mk_agent/plugins
dodir /etc/check_mk

dodoc doc/{AUTHORS,COPYING,ChangeLog}
docompress

if use xinetd; then
insinto /etc/xinetd.d
newins cfg_examples/xinetd.conf check_mk
systemd_dounit cfg_examples/systemd/check_mk{.socket,@.service}
fi

# Install the check_mk_agent logwatch plugin
if use logwatch; then
insinto /etc/check_mk
doins cfg_examples/logwatch.cfg
exeinto /usr/lib/check_mk_agent/plugins
doexe plugins/mk_logwatch
fi

# Install any other useflag-enabled agent plugins
exeinto /usr/lib/check_mk_agent/plugins
use inventory && newexe plugins/mk_inventory.linux mk_inventory
use smart && doexe plugins/smart
use mysql && doexe plugins/mk_mysql
use postgres && doexe plugins/mk_postgres
use apache_status && doexe plugins/apache_status
use zypper && doexe plugins/mk_zypper
use oracle && doexe plugins/mk_oracle
use nfsexports && doexe plugins/nfsexports
}
1 change: 1 addition & 0 deletions net-analyzer/check_mk_agent/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,7 @@
Nagios/Icigna centralized monitoring servers.
</longdescription>
<use>
<flag name="inventory">Install check_mk-agent linux inventory plugin.</flag>
<flag name="logwatch">Install check_mk-agent logwatch plugin.</flag>
<flag name="smart">Install check_mk-agent S.M.A.R.T plugin.</flag>
<flag name="mysql">Install check_mk-agent mysql plugin.</flag>
Expand Down

0 comments on commit 51d4359

Please sign in to comment.