Skip to content

Commit

Permalink
dev-libs/libphonenumber: 8.12.39 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Dec 20, 2021
1 parent d786917 commit 521d670
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libphonenumber/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libphonenumber-8.12.37.tar.gz 11005274 BLAKE2B 2bcffe898ca7aa667a35e9a7340a54f880cdb9f290e807e9ff7f6ee778df83dd80023703595781a97355a43a8096bdc957a7f79336b5bf9d892ada26e35ae025 SHA512 420ea841679c1ff420289b3fea0bb6d86d4d1e99525fce00cc90025c8ade99e56e2dcbb7fca64190437ff0a889cdc7373f182e7699db20a072c32e984b8dff33
DIST libphonenumber-8.12.39.tar.gz 11007180 BLAKE2B 27a47b35497772740da04cb9b79e1a6b4fd6f9b0d4a89768e1ba9212672f1a0fd06c5837aa8858a4680b5c47ef16721c6ef145d8d2cd77dccbe27bb4b0897dcf SHA512 82570c60b132022a713c0664de2c29997cff0ab8c3ab97dbec0f8d1cd1782090ba92ca7d2f044760f523c986660f13b70aacf8a9c247a3b80eb19d35227bc2a8
48 changes: 48 additions & 0 deletions dev-libs/libphonenumber/libphonenumber-8.12.39.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

CMAKE_MAKEFILE_GENERATOR="emake" # broken w/ ninja
inherit cmake

DESCRIPTION="Library for parsing, formatting, and validating international phone numbers"
HOMEPAGE="https://github.com/google/libphonenumber"
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
CMAKE_USE_DIR="${WORKDIR}"/${P}/cpp

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="test"

RESTRICT="test !test? ( test )"

DEPEND="
dev-libs/icu:=
dev-libs/protobuf:=
dev-libs/boost:=
"
RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
test? ( dev-cpp/gtest )
"

PATCHES=(
# it is either this, or disable BUILD_GEOCODER
# https://github.com/google/libphonenumber/pull/2556
"${FILESDIR}"/${PN}-8.12.37-cmake.patch
# see also https://github.com/google/libphonenumber/pull/2459
# using a stripped-down patch w/ BUILD_TESTING
"${FILESDIR}"/${PN}-8.12.37-testing.patch
)

src_configure() {
local mycmakeargs=(
-DBUILD_STATIC_LIB=OFF
-DBUILD_TESTING=$(usex test)
-DREGENERATE_METADATA=OFF # avoid JRE dependency
)
cmake_src_configure
}

0 comments on commit 521d670

Please sign in to comment.