Skip to content

Commit

Permalink
games-puzzle/wizznic: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Michael Sterrett committed Mar 31, 2016
1 parent 2a36e8a commit 52df6e2
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-puzzle/wizznic/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Wizznic_src_build_306.tar.bz2 37019286 SHA256 864b51e20f97b918950d20631c8498e44ea55b8a79a64041ae60b73fa9a5926d SHA512 499b43bf8d1fe4b187e0a3c1f186fbd629ae7a7b3fa993d581b4db2a7f5025d44381f001fe5f3ca769d882040c4ae07d30f53025f119502cfa6f5a97e109ae54 WHIRLPOOL 6fd49bb67dd76a3ac7f8528a98961f1723fd097e9d8bb327edba34d921a711841f5a40c1788ddfc8e3db1ece1c1e0054054002deb462abb80c1e226055dac7f4
DIST Wizznic_src_build_369.tar.bz2 38118227 SHA256 8eac5fbdfdeae70f22cde84eea4c57ab9576e99db3d38b75aae795d32f64dee5 SHA512 61c6ced873403bbd14e8c376321ae0c92a7333bb59409615de1e1305da3e4b3cb023af36e002d732877fd1371a322796df3e4050e5afe699e03f01039d7f7ead WHIRLPOOL f9a40898a8c830fa55b1fb278baa0d9dcf874427ea2b7216d0ec10e4334936c979cafd61f6e4551d351c4f97803f0ce47ecbf2b061e641c2cb1142ddec956f84
50 changes: 50 additions & 0 deletions games-puzzle/wizznic/wizznic-369.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils games

DESCRIPTION="Block-clearing puzzle game"
HOMEPAGE="http://wizznic.org/"
SRC_URI="mirror://sourceforge/wizznic/Wizznic_src_build_${PV}.tar.bz2"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="media-libs/libsdl[sound,joystick,opengl,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
virtual/opengl"
RDEPEND=${DEPEND}

S=${WORKDIR}/Wizznic_src_build_${PV}

src_prepare() {
sed \
-e '/^\(CC\|LD\|STRIP\)/d' \
-e 's/(LD)/(CC)/g' \
-e '/CFLAGS.*=/d' \
Makefile.linux > Makefile || die
}

src_compile() {
emake \
DATADIR="${GAMES_DATADIR}/${PN}/" \
BINDIR="${GAMES_BINDIR}" \
STRIP=true
}

src_install() {
emake \
DESTDIR="${D}" \
DATADIR="${GAMES_DATADIR}/${PN}/" \
BINDIR="${GAMES_BINDIR}" \
install
dodoc doc/{changelog.txt,credits.txt,media-licenses.txt,ports.txt,readme.txt}
newicon data/wmicon.png ${PN}.png
make_desktop_entry wizznic "Wizznic!"
prepgamesdirs
}

0 comments on commit 52df6e2

Please sign in to comment.