forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-simulation/flightgear: Version bump 2018.3.1
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Maciej Mrozowski <[email protected]>
- Loading branch information
Showing
7 changed files
with
268 additions
and
5 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST simgear-2018.1.1.tar.bz2 1303653 BLAKE2B 44b98c2ba8ae292c3736d04813869df528d7ca14bbdc1773e1f4bd4b7b4899b5fd8605a7ada5dcc2d5e863e82ee2f1e1d2b980d3bd775c92325ad3ca834306c3 SHA512 3de7a15dc7b60e9e7466950c1b466d0daefea84b4730a9b8cf5e26c41cece5fd03ccf57b0f3cb977093482beb734560812e347003e19e0bb4b40d81820a11563 | ||
DIST simgear-2018.2.1.tar.bz2 1314943 BLAKE2B 60e44896d466085014020874a1be6ab3f6f87e472f985237404dffb5dfbd5c25f0d330701276e0b8d075830695872eb7521bb4eb5b0107edac5977c3aab85bf7 SHA512 6756994e0688a1f3699c33548ea90b19e99a439ea2f2002cf524629370cd1161a1556ee966fc3a781141fc7a08e7574adc0ecbe6dec67e72d631c6c4d744e4dd | ||
DIST simgear-2018.3.1.tar.bz2 1330322 BLAKE2B 5b350ddce726d8ea15c4a1a64a28b9e4307647378c52989231daa7b4a0e53730dc754c239660d0f5ec33189ece6629448b37f61ca7578c21c3aa4147d4565a26 SHA512 673ee76e9f4f9c9adb25a2523bad5b70a079d821391cb8fc9f9e651ad6c195356ac9a8ba18a65df365dc66990406de287099fb249ca23eefc111ebba884f7289 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils toolchain-funcs | ||
|
||
DESCRIPTION="Development library for simulation games" | ||
HOMEPAGE="http://www.simgear.org/" | ||
SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+dns debug gdal openmp subversion test" | ||
|
||
COMMON_DEPEND=" | ||
dev-libs/expat | ||
>=dev-games/openscenegraph-3.2.0 | ||
media-libs/openal | ||
net-misc/curl | ||
sys-libs/zlib | ||
virtual/opengl | ||
dns? ( net-libs/udns ) | ||
gdal? ( sci-libs/gdal ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.44 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
subversion? ( dev-vcs/subversion ) | ||
" | ||
|
||
pkg_pretend() { | ||
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp | ||
} | ||
|
||
pkg_setup() { | ||
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DENABLE_DNS=$(usex dns) | ||
-DENABLE_GDAL=$(usex gdal) | ||
-DENABLE_OPENMP=$(usex openmp) | ||
-DENABLE_PKGUTIL=ON | ||
-DENABLE_RTI=OFF | ||
-DENABLE_SIMD=ON | ||
-DENABLE_SOUND=ON | ||
-DENABLE_TESTS=$(usex test) | ||
-DSIMGEAR_HEADLESS=OFF | ||
-DSIMGEAR_SHARED=ON | ||
-DSYSTEM_EXPAT=ON | ||
-DSYSTEM_UDNS=ON | ||
-DUSE_AEONWAVE=OFF | ||
-DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it | ||
) | ||
cmake-utils_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST FlightGear-2018.1.1-data.tar.bz2 1576049981 BLAKE2B cfcf028ca04ed785ba7c65979e6566ab773d8af869a9b62050969295eafecf7d1f5b6162f498af96786fa23a46e886390f240b56c83e7107473f59552a1155a5 SHA512 022f102f95c9cd8b153d991dad55ecd182e71aa0f3ecfe1502a35d6dcda0746a1fd183f808e59aba8c7f3a0cc9ae1f2f91ff49565bff4c7bc5a1c4889fcc127f | ||
DIST FlightGear-2018.2.1-data.tar.bz2 1624676603 BLAKE2B baecea2002fc3c256205e70c6692102f9bccd04c839902353b0e6d803a97221479e8b54095530dc7af366d842c487d04447f0fd775527e6f5ea0ac32ed602dd6 SHA512 93690703965dd83b610ea0ba67938c0d3fb2d5f6d8c842851a979f352387431eacafb4d181a56dad6def474b2ab84f412cf5531570ce18c1ec80076fe92e4d05 | ||
DIST FlightGear-2018.3.1-data.tar.bz2 1735407015 BLAKE2B e076e0096656c607cd32c7f86999685bc65bc1d8a28a260e0e7d760a5d4ea645f3a84f8410f9091e9767fcc143d0910f3e2ac2546e9408a49032b864bdd3c742 SHA512 495ef2dc87244c10cbca6deed7731e84f07c4a495e6d70ea7a88581e655b366c17900603f2388d2d21c4fe5cc4279820ae2a112376deeba4d37a53cd3495c102 |
26 changes: 26 additions & 0 deletions
26
games-simulation/flightgear-data/flightgear-data-2018.3.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DESCRIPTION="FlightGear data files" | ||
HOMEPAGE="http://www.flightgear.org/" | ||
SRC_URI="mirror://sourceforge/flightgear/FlightGear-${PV}-data.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
# data files split to separate package since 2.10.0 | ||
RDEPEND=" | ||
!<games-simulation/flightgear-2.10.0 | ||
" | ||
|
||
S=${WORKDIR}/fgdata | ||
|
||
src_install() { | ||
insinto /usr/share/flightgear | ||
rm -fr .git | ||
doins -r * | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST flightgear-2018.1.1.tar.bz2 8158999 BLAKE2B 5d7ca65c0b2627c7b34681e0af8e060f67cbed80d7e313c056fb92f026bc2355af66bbb6b377573db32f5101c63f1fa04521ba7fdffd584a56ae1049d1bcce83 SHA512 962be602a8c294081109ee1893383ac22dd83a0511fdb600d24d5dc9eca24d19687eaeed545695259502431e6d8c8bcdafe26846636ad40be28f5c2e4b0cfe93 | ||
DIST flightgear-2018.2.1.tar.bz2 8344999 BLAKE2B fc5fbd43bcc2e40ed3245aa5059b0e5a40918a707cbddc8383de191e29f6cdfaa6960f6cfffb201b20ad10f5da0f343a693768d38be2788fd2582f7b5dc2419c SHA512 d308eebf6d6017794c086d534f6543c03a54e55bd7f48caf8359d5a84776406eac8cd8f32252efb2cd8bbb82c9c15fe4d7e3229ff2483e7a9772bd532331be03 | ||
DIST flightgear-2018.3.1.tar.bz2 8404294 BLAKE2B b90d64bc7381baef3adf3f2b77acb6822562d76319e85bebeda977754c281cd48b4ce137d910cc9f96947cfe1b7612c6ff45f2ed49775348b651944bb8796ba4 SHA512 ad07cdf90b1890519a22a1f79374b2d11e70191d85bc76d50913708a250801c3e091228999011367e374572a46c60f572f8b138d6a7c9fd2155f63107667d93c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,159 @@ | ||
# Copyright 1999-2018 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils bash-completion-r1 toolchain-funcs | ||
|
||
DESCRIPTION="Open Source Flight Simulator" | ||
HOMEPAGE="http://www.flightgear.org/" | ||
SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
KEYWORDS="~amd64 ~x86" | ||
SLOT="0" | ||
IUSE="dbus debug examples gdal openmp qt5 +udev +utils vim-syntax" | ||
|
||
# Needs --fg-root with path to flightgear-data passed to test runner passed, | ||
# not really worth patching | ||
RESTRICT="test" | ||
|
||
# zlib is some strange auto-dep from simgear | ||
COMMON_DEPEND=" | ||
dev-db/sqlite:3 | ||
>=dev-games/openscenegraph-3.2.0[jpeg,png] | ||
~dev-games/simgear-${PV}[gdal=] | ||
media-libs/openal | ||
>=media-libs/speex-1.2.0:0 | ||
media-libs/speexdsp:0 | ||
media-sound/gsm | ||
sys-libs/zlib | ||
virtual/glu | ||
x11-libs/libX11 | ||
dbus? ( >=sys-apps/dbus-1.6.18-r1 ) | ||
gdal? ( >=sci-libs/gdal-2.0.0:0 ) | ||
qt5? ( | ||
>=dev-qt/qtcore-5.7.1:5 | ||
>=dev-qt/qtdeclarative-5.7.1:5 | ||
>=dev-qt/qtgui-5.7.1:5 | ||
>=dev-qt/qtnetwork-5.7.1:5 | ||
>=dev-qt/qtwidgets-5.7.1:5 | ||
) | ||
udev? ( virtual/udev ) | ||
utils? ( | ||
media-libs/freeglut | ||
media-libs/freetype:2 | ||
media-libs/glew:0 | ||
media-libs/libpng:0 | ||
virtual/opengl | ||
qt5? ( >=dev-qt/qtwebsockets-5.7.1:5 ) | ||
) | ||
" | ||
# libXi and libXmu are build-only-deps according to FindGLUT.cmake | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.44 | ||
>=media-libs/plib-1.8.5 | ||
utils? ( | ||
x11-libs/libXi | ||
x11-libs/libXmu | ||
) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
~games-simulation/${PN}-data-${PV} | ||
" | ||
|
||
DOCS=(AUTHORS ChangeLog NEWS README Thanks) | ||
|
||
pkg_pretend() { | ||
use openmp && tc-check-openmp | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DENABLE_AUTOTESTING=OFF | ||
-DENABLE_FGCOM=$(usex utils) | ||
-DENABLE_FGELEV=$(usex utils) | ||
-DENABLE_FGJS=$(usex utils) | ||
-DENABLE_FGVIEWER=$(usex utils) | ||
-DENABLE_FLITE=OFF | ||
-DENABLE_GDAL=$(usex gdal) | ||
-DENABLE_GPSSMOOTH=$(usex utils) | ||
-DENABLE_HID_INPUT=$(usex udev) | ||
-DENABLE_JS_DEMO=$(usex utils) | ||
-DENABLE_JSBSIM=ON | ||
-DENABLE_LARCSIM=ON | ||
-DENABLE_METAR=$(usex utils) | ||
-DENABLE_OPENMP=$(usex openmp) | ||
-DENABLE_PLIB_JOYSTICK=ON # NOTE look for defaults changes in CMake | ||
-DENABLE_PROFILE=OFF | ||
-DENABLE_QT=$(usex qt5) | ||
-DENABLE_RTI=OFF | ||
-DENABLE_STGMERGE=ON | ||
-DENABLE_TERRASYNC=$(usex utils) | ||
-DENABLE_TRAFFIC=$(usex utils) | ||
-DENABLE_UIUC_MODEL=ON | ||
-DENABLE_YASIM=ON | ||
-DEVENT_INPUT=$(usex udev) | ||
-DFG_BUILD_TYPE=Release | ||
-DFG_DATA_DIR=/usr/share/${PN} | ||
-DJSBSIM_TERRAIN=ON | ||
-DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO also see simgear | ||
-DSP_FDMS=ON | ||
-DSYSTEM_CPPUNIT=OFF # NOTE we do not build tests anyway | ||
-DSYSTEM_FLITE=ON | ||
-DSYSTEM_HTS_ENGINE=ON | ||
-DSYSTEM_SPEEX=ON | ||
-DSYSTEM_GSM=ON | ||
-DSYSTEM_SQLITE=ON | ||
-DUSE_AEONWAVE=OFF | ||
-DUSE_DBUS=$(usex dbus) | ||
-DWITH_FGPANEL=$(usex utils) | ||
) | ||
if use gdal && use utils; then | ||
mycmakeargs+=(-DENABLE_DEMCONVERT=ON) | ||
else | ||
mycmakeargs+=(-DENABLE_DEMCONVERT=OFF) | ||
fi | ||
if use qt5 && use utils; then | ||
mycmakeargs+=(-DENABLE_FGQCANVAS=ON) | ||
else | ||
mycmakeargs+=(-DENABLE_FGQCANVAS=OFF) | ||
fi | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
|
||
# Install bash completion (TODO zsh) | ||
# Uncomment below when scripts stops writing files... | ||
# sed -e "s|/usr/local/share/FlightGear|${GAMES_DATADIR}/${PN}|" \ | ||
# -i scripts/completion/fg-completion.bash || die 'unable to replace FG_ROOT' | ||
# newbashcomp scripts/completion/fg-completion.bash ${PN} | ||
|
||
# Install examples and other misc files | ||
if use examples; then | ||
insinto /usr/share/doc/"${PF}"/examples | ||
doins -r scripts/java scripts/perl scripts/python | ||
insinto /usr/share/doc/"${PF}"/examples/c++ | ||
doins -r scripts/example/* | ||
insinto /usr/share/doc/"${PF}"/tools | ||
doins -r scripts/atis scripts/tools/* | ||
fi | ||
|
||
# Install nasal script syntax | ||
if use vim-syntax; then | ||
insinto /usr/share/vim/vimfiles/syntax | ||
doins scripts/syntax/{ac3d,nasal}.vim | ||
insinto /usr/share/vim/vimfiles/ftdetect/ | ||
doins "${FILESDIR}"/{ac3d,nasal}.vim | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
einfo "Please note that data files location changed to /usr/share/flightgear" | ||
if use qt5; then | ||
einfo "To use launcher, run fgfs with '--launcher' parameter" | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters