Skip to content

Commit

Permalink
dev-php/pecl-redis: Version bump to new slot wrt bug 585912
Browse files Browse the repository at this point in the history
This ebuild pulls in the old slot for targets it does not support

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
Brian Evans committed Jun 14, 2016
1 parent bcfe28f commit 558106c
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-redis/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST redis-2.2.7.tgz 134340 SHA256 95e5331cd7e709771eb4479c455bcf326a74b2aea3b1a5cba00b4c95e66dc902 SHA512 88be2abeda62b7c1c95b6d399bbb5f97774d956001b4d13a8e5f183e86fe6336d91f479a8125adcaeff1ad5617a920953961360fc3484ebafc3ed915bcd7f86c WHIRLPOOL e7c8ea7c0c4578933211d4571d742ad09eadb5dd93e207d4f0d5858bfacb7a78eb4bd7ed34cafbc17b465b0d423ea0ff788dee907d89c4939ee4a9acbbe8b95d
DIST redis-3.0.0.tgz 189720 SHA256 de0e349027ea0821fbfb7f1961226223f3179bb84c6dada515f0145227993f70 SHA512 0dc4a6363e6bcefdbb50abec500558aaf709ca4e418d11dcebc15509684c81c5286781003725346d7ff748d8b4eea9735cdc82dc9c37fa54c8e7009f6e8bc494 WHIRLPOOL fa612b130ff6611425a4a7e3bb85c40148c006627fce04cd3fd1efcbdbe4780bb3cd3cdb2483d9c385eadf3ba97b82ffd43c906611dd8b5f03b4272a0e24bc4e
41 changes: 41 additions & 0 deletions dev-php/pecl-redis/pecl-redis-3.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PHP_EXT_NAME="redis"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"

USE_PHP="php5-6 php7-0"

DOCS="arrays.markdown README.markdown"

inherit php-ext-pecl-r2

#redefine in order to only build for 7.0
USE_PHP="php7-0"

KEYWORDS="~amd64"

DESCRIPTION="PHP extension for interfacing with Redis"
LICENSE="PHP-3.01"
SLOT="7"
IUSE="igbinary"

DEPEND="igbinary? ( php_targets_php7-0? ( dev-php/igbinary[php_targets_php7-0] ) )"
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-redis:0 )"

src_configure() {
my_conf="--enable-redis
$(use_enable igbinary redis-igbinary)"

php-ext-source-r2_src_configure
}

src_install() {
if use php_targets_php7-0 ; then
php-ext-pecl-r2_src_install
fi
}

0 comments on commit 558106c

Please sign in to comment.