Skip to content

Commit

Permalink
app-vim/youcompleteme: Switch to PYTHON_MULTI_USEDEP API
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 9, 2020
1 parent 2f385a3 commit 558eef3
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 17 deletions.
12 changes: 7 additions & 5 deletions app-vim/youcompleteme/youcompleteme-20130910.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -26,13 +26,15 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
clang? ( >=sys-devel/clang-3.3 )
|| (
app-editors/vim[python,${PYTHON_USEDEP}]
app-editors/gvim[python,${PYTHON_USEDEP}]
app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
)"
DEPEND="${RDEPEND}
test? (
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
>=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/mock-1.0.1[${PYTHON_MULTI_USEDEP}]
>=dev-python/nose-1.3.0[${PYTHON_MULTI_USEDEP}]
')
)"

CMAKE_IN_SOURCE_BUILD=1
Expand Down
30 changes: 18 additions & 12 deletions app-vim/youcompleteme/youcompleteme-99999999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -26,26 +26,32 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
COMMON_DEPEND="
${PYTHON_DEPS}
clang? ( >=sys-devel/clang-3.3 )
dev-libs/boost[python,threads,${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-libs/boost[python,threads,${PYTHON_MULTI_USEDEP}]
')
|| (
app-editors/vim[python,${PYTHON_USEDEP}]
app-editors/gvim[python,${PYTHON_USEDEP}]
app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
)
"
RDEPEND="
${COMMON_DEPEND}
dev-python/bottle[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
dev-python/jedi[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/sh[${PYTHON_USEDEP}]
dev-python/waitress[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/bottle[${PYTHON_MULTI_USEDEP}]
virtual/python-futures[${PYTHON_MULTI_USEDEP}]
dev-python/jedi[${PYTHON_MULTI_USEDEP}]
dev-python/requests[${PYTHON_MULTI_USEDEP}]
dev-python/sh[${PYTHON_MULTI_USEDEP}]
dev-python/waitress[${PYTHON_MULTI_USEDEP}]
')
"
DEPEND="
${COMMON_DEPEND}
test? (
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
>=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/mock-1.0.1[${PYTHON_MULTI_USEDEP}]
>=dev-python/nose-1.3.0[${PYTHON_MULTI_USEDEP}]
')
>=dev-cpp/gtest-1.8.0
)
"
Expand Down

0 comments on commit 558eef3

Please sign in to comment.