Skip to content

Commit

Permalink
www-client/opera-developer: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Jeroen Roovers committed Nov 7, 2016
1 parent da8d6c6 commit 55bbe75
Show file tree
Hide file tree
Showing 2 changed files with 93 additions and 0 deletions.
2 changes: 2 additions & 0 deletions www-client/opera-developer/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST opera-developer_42.0.2372.0_amd64.deb 48540414 SHA256 f1f15d176eaa09919b3f9
DIST opera-developer_42.0.2372.0_i386.deb 49083570 SHA256 4afb6aec7382ea46a9b2cd0943d85234e56e4b7a5dc0949a36bc89763841063f SHA512 b2ff1aa8a1ac2556e2a10db3347c7922ab5297ae713ed76916da470c2b13d440dee22f1c2ecfa09b4d65ee595b8c65b12e756b15131b652813f549a5d5e4225b WHIRLPOOL a93c028d9fb7dbb897a8802b01eb2bfa7deb3d61a4be6abbba6e0d9de1f256a13a403a4d499b6dc34fadd4e6e231a9f44881177e1ac7892635df11a1c070cb38
DIST opera-developer_42.0.2392.0_amd64.deb 49212674 SHA256 f5f8bb7337b836f99371f0f63ee3f24bf00d357b4f763a475888b900f7b803f7 SHA512 f7e4210a6f5b68d6f1e489c09f607f30205057bcf1f174e8ce467b3590a5e9cba38c2f2c23d4014e2df919dbf31438f72d8d07dbe7588dd7577a0b195d62a9a1 WHIRLPOOL 266c3ef11b45c721bc7f8669f7ff955355134cb96c8ddedd5df03461f065128b12e76eee0eb506d1fe73cc8355aa2e5786102d466da781bcb64b2e546cf75060
DIST opera-developer_42.0.2392.0_i386.deb 50381802 SHA256 ee126cad212a46420e2dd52a1a200e5df7feb1057b92d758a9f3d58cd656f5e7 SHA512 b94e04df4082d377d4542ad72536aa82377764bfa4380b43672e877c54198dbd751243dbb93fc352cedbd49fd1a8d15d28087c44c352a10e38e554d89afd18b6 WHIRLPOOL 749bb7731287b101c25d410c5ee46dc70f4c99d627b489da20841d6f068e345a9fb197231ad32ac2e5aa93838c7258080ddede4119e335bf8f4e285ecf2e83c7
DIST opera-developer_43.0.2403.0_amd64.deb 49889634 SHA256 a3469b3877d454cd12567659ec3de6ff75681d56d176070f4c4ad0d9ce075391 SHA512 767305cd1473792bb8e731822cdf44cd2627141d9c44c94ac30f6247d6ca8052ce1c143cb52b204ede22d4df0867e400b2d6bf4756037e452f582834055825c9 WHIRLPOOL 5751b4e94de112c1b85d2485d7aeb5f06cdc42a2131e3e2782b146e9701433bae84e2458702e458c933b4916615ea7fdb50a9016dc6e970a1fe1b841c3038044
DIST opera-developer_43.0.2403.0_i386.deb 51411876 SHA256 71339134c9cd89895f80caea2bae4a0a5a7e312630e3b19c4280314d66738125 SHA512 e9a81b4241a158b912a47b53ff44a2d50991fe8d2e54131d8f6006131f9eda2206f214d085615a3b504167501fe641e8fabc3527128a93a9d13e88c280f2648a WHIRLPOOL 9a3c121c967bcebc67eac811c2ae12171af436c8eddaa94ad6986d1658256e3077ad7a43ef192a45100138c88cea941a5d4afc26f1dce7a7a22fd9bf9ecd2908
91 changes: 91 additions & 0 deletions www-client/opera-developer/opera-developer-43.0.2403.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
CHROMIUM_LANGS="
af az be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA fy gd
he hi hr hu id it ja kk ko lt lv mk ms nb nl nn pa pl pt-BR pt-PT ro ru sk
sr sr-ME sv sw ta te th tr uk uz vi zh-CN zh-TW zu
"
inherit chromium-2 multilib unpacker

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="http://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="http://get.geo.opera.com/pub/"
SRC_URI="
amd64? ( "${SRC_URI_BASE}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb" )
x86? ( "${SRC_URI_BASE}${PN}/${PV}/linux/${PN}_${PV}_i386.deb" )
"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}
OPERA_HOME="usr/$(get_libdir)/${PN}"

src_unpack() {
unpack_deb ${A}
}

src_prepare() {
case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
x86)
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
;;
esac

rm usr/bin/${PN} || die

rm usr/share/doc/${PN}/copyright || die
mv usr/share/doc/${PN} usr/share/doc/${PF} || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

0 comments on commit 55bbe75

Please sign in to comment.