Skip to content

Commit

Permalink
app-shells/thefuck: Fix dependencies for python2.7
Browse files Browse the repository at this point in the history
Gentoo-Bug: 589110

Package-Manager: portage-2.3.0
  • Loading branch information
mrueg committed Sep 4, 2016
1 parent 3192a0a commit 56008b7
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions app-shells/thefuck/thefuck-3.11-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=(python{2_7,3_4})

inherit distutils-r1

DESCRIPTION="Magnificent app which corrects your previous console command"
HOMEPAGE="https://github.com/nvbn/thefuck"
SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"

LICENSE="MIT"
SLOT="0"
IUSE="test"

RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)"
DEPEND="test? ( ${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"

src_prepare() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
distutils-r1_src_prepare
}

python_test() {
py.test || die
}

0 comments on commit 56008b7

Please sign in to comment.