Skip to content

Commit

Permalink
dev-python/inflect: v4.0.0, stops supporting Py<3.6, add Py3.8
Browse files Browse the repository at this point in the history
Also switch to distutils_enable_sphinx.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Louis Sautier <[email protected]>
  • Loading branch information
sbraz committed Dec 30, 2019
1 parent 84575c4 commit 5674bc7
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/inflect/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST inflect-0.2.5.tar.gz 109756 BLAKE2B ecb64b0fea04602f112dfba11ade6828eae7a7f3f44d4c4fb15c2300ac18025ea4c51f9c36aae5e7e92bd09e24d08091ce096b888a520fd2d4c40374356333d5 SHA512 68371158ac90d9662c19657cbf697f44ee9ceac090286d53e29ee04252efbb7d0bfbd99ae6847e6eec1991ef4ef670eff60693d1f0a301885bab2a09c7ce4616
DIST inflect-2.1.0.tar.gz 98767 BLAKE2B 2cddbeb7d4ca5e150435e42b75e0eff2e2b20a8cf38c89fe6e8958bc52d69aa070f7ba5c6c73bfdd2dab585ceb32006542f31abbeccc2375760742c70e0c6c50 SHA512 c5230ad6f224a6e9667ce3c135bf43d09939bf457f68fb3d52a4278b110df10c9ddddd05e68d94f04a6902319ad71440440bad019c081d0d781a2dbde9ab98bc
DIST inflect-3.0.2.tar.gz 71546 BLAKE2B 951eb818ba1645a9e426468811ad449378aa5a7341575ac2aff5e9d1e06237fe8e96fa64cd678665cd6c05e1dc5e477a65b261b9d8bd170be4fb923d5fb90e9c SHA512 5858548e947f742b91630fc584f568a2221057ada7cd4a55f39de1b52a82c97884d6a78c2f32e5995e354fd1c4eae4d5b3d30491ef57dd5187fd6baca93d2779
DIST inflect-4.0.0.tar.gz 71091 BLAKE2B 597db3d84cce1660ea92b84af5d07d77f537b2d738caedbe132ed9cb074a3c80c2f9e1cab321f0e231b2a29803f3b25206f27b78672c4917873007f3a56f1a8a SHA512 7d9ef9389b9301e596165fcb1774467ddeb421636094a0f0cebbcaa11558b4529ccb90644e1097f91cff3316911c98f4bb1df92180193a5313ca7da91a282e5c
41 changes: 41 additions & 0 deletions dev-python/inflect/inflect-4.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( pypy3 python3_{6,7,8} )

inherit distutils-r1

DESCRIPTION="Correctly inflect words and numbers"
HOMEPAGE="https://github.com/jazzband/inflect"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
"
# six can be removed in the next release
# https://github.com/jazzband/inflect/commit/407dfa7e170a562012f37e9bd65c3b50cd3da0cb
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
)
"

distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
'>=dev-python/rst-linker-1.9' dev-python/alabaster

python_test() {
# Override pytest options to skip flake8
pytest -vv tests --override-ini="addopts=--doctest-modules" \
|| die "tests failed with ${EPYTHON}"
}

0 comments on commit 5674bc7

Please sign in to comment.