Skip to content

Commit

Permalink
dev-java/xmpbox: new package
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo#23244
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
vaukai authored and fordfrog committed Dec 20, 2021
1 parent 1ccc0d1 commit 57cd174
Show file tree
Hide file tree
Showing 3 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/xmpbox/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST pdfbox-2.0.24-src.zip 15651754 BLAKE2B 5d0220c28c2be18a66aa66c2540d3e1d85ecc6826f632e6c9a0193f2f02dca645909b0a54c707d856bb2886d52b0b5fb706503b4f89f0eb7aede8e612bebfa8e SHA512 5d55b3cadbbae266d90c47f5b10c9b09b6dc16f53b77a0cf15c78e62fc69afc7b6eab5a4329608ecdf25de9194b38db1f7d23e7d71af473cc1bf7b09b0028642
10 changes: 10 additions & 0 deletions dev-java/xmpbox/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
</maintainer>
<longdescription>
The Apache XmpBox library is an open source Java tool that implements Adobe's XMP(TM) specification. It can be used to parse, validate and create xmp contents. It is mainly used by subproject preflight of Apache PDFBox. XmpBox is a subproject of Apache PDFBox.
</longdescription>
</pkgmetadata>
64 changes: 64 additions & 0 deletions dev-java/xmpbox/xmpbox-2.0.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://ftp.halifax.rwth-aachen.de/gentoo/distfiles/cc/pdfbox-2.0.24-src.zip --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild xmpbox-2.0.24.ebuild

EAPI=8

JAVA_PKG_IUSE="doc source test"
MAVEN_ID="org.apache.pdfbox:xmpbox:2.0.24"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="An open source Java tool that implements Adobe's XMP(TM) specification."
HOMEPAGE="https://pdfbox.apache.org"
SRC_URI="mirror://apache/pdfbox/${PV}/pdfbox-${PV}-src.zip"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"

# Common dependencies
# POM: pom.xml
# commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0

CP_DEPEND="dev-java/jaxb-api:2"

# Compile dependencies
# POM: pom.xml
# javax.xml.bind:jaxb-api:2.3.1 -> !!!groupId-not-found!!!
# POM: pom.xml
# test? junit:junit:4.13.2 -> >=dev-java/junit-4.13.2:4

DEPEND="${CP_DEPEND}
>=virtual/jdk-1.8:*"

RDEPEND="${CP_DEPEND}
>=virtual/jre-1.8:*"

BDEPEND="app-arch/unzip"

DOCS=( README.txt )

S="${WORKDIR}/pdfbox-${PV}/${PN}"

JAVA_CLASSPATH_EXTRA="jaxb-api-2"
JAVA_SRC_DIR="src/main/java"

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
JAVA_TEST_RESOURCE_DIRS="src/test/resources"

JAVA_TEST_EXCLUDES=(
# 1) initializationError(org.apache.xmpbox.parser.PropMappingTest)
# org.junit.runners.model.InvalidTestClassError: Invalid test class 'org.apache.xmpbox.parser.PropMappingTest':
# 1. No runnable methods
org.apache.xmpbox.parser.PropMappingTest
)

src_install() {
default # https://bugs.gentoo.org/789582
java-pkg-simple_src_install
}

0 comments on commit 57cd174

Please sign in to comment.