Skip to content

Commit

Permalink
kde-plasma/plasma-workspace: Fix krunner regression to use cwd "~"
Browse files Browse the repository at this point in the history
Reported-by: Andrea <[email protected]>
Tested-by: Marquel (in #plasma), but also myself
Closes: https://bugs.gentoo.org/767478
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Feb 5, 2021
1 parent 5c041cf commit 57de3a3
Show file tree
Hide file tree
Showing 2 changed files with 265 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
From e350342bfc42f7803c58dafea0c0ad190507430b Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <[email protected]>
Date: Tue, 2 Feb 2021 13:28:06 +0100
Subject: [PATCH] Revert "Activate KRunner instead of running the binary"

Causes applications to be started with cwd "/".

See also: https://bugs.gentoo.org/767478

This reverts commit 0e575a20ef36532b5b40a40ea30f915976942477.
---
krunner/CMakeLists.txt | 3 ++-
krunner/{krunner.desktop => krunner.desktop.cmake} | 4 ++--
2 files changed, 4 insertions(+), 3 deletions(-)
rename krunner/{krunner.desktop => krunner.desktop.cmake} (94%)

diff --git a/krunner/CMakeLists.txt b/krunner/CMakeLists.txt
index 59d50e464..02b2c5731 100644
--- a/krunner/CMakeLists.txt
+++ b/krunner/CMakeLists.txt
@@ -31,7 +31,8 @@ target_compile_definitions(krunner PRIVATE -DPROJECT_VERSION="${PROJECT_VERSION}
install(TARGETS krunner ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
install(FILES ${krunner_dbusAppXML} DESTINATION ${KDE_INSTALL_DBUSINTERFACEDIR} )

-install(FILES krunner.desktop DESTINATION ${DATA_INSTALL_DIR}/kglobalaccel)
+configure_file(krunner.desktop.cmake ${CMAKE_CURRENT_BINARY_DIR}/krunner.desktop @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/krunner.desktop DESTINATION ${DATA_INSTALL_DIR}/kglobalaccel)

set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/KRunnerAppDBusInterface")
configure_package_config_file(KRunnerAppDBusInterfaceConfig.cmake.in
diff --git a/krunner/krunner.desktop b/krunner/krunner.desktop.cmake
similarity index 94%
rename from krunner/krunner.desktop
rename to krunner/krunner.desktop.cmake
index 85c91dbad..457daaaa7 100644
--- a/krunner/krunner.desktop
+++ b/krunner/krunner.desktop.cmake
@@ -1,5 +1,5 @@
[Desktop Entry]
-Exec=dbus-send --type=method_call --dest=org.kde.krunner /App org.kde.krunner.App.display
+Exec=@CMAKE_INSTALL_PREFIX@/bin/krunner
Name=KRunner
Name[ar]=مشغّل.ك
Name[ast]=KRunner
@@ -59,7 +59,7 @@ Actions=RunClipboard
X-KDE-Wayland-Interfaces=org_kde_plasma_window_management

[Desktop Action RunClipboard]
-Exec=dbus-send --type=method_call --dest=org.kde.krunner /App org.kde.krunner.App.displayWithClipboardContents
+Exec=krunner -c
Name=Run command on clipboard contents
Name[az]=Əmri, mübadilə buferindən başlatmaq
Name[ca]=Executa una ordre al contingut del porta-retalls
--
2.30.0

209 changes: 209 additions & 0 deletions kde-plasma/plasma-workspace/plasma-workspace-5.20.5-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,209 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ECM_HANDBOOK="forceoptional"
ECM_TEST="forceoptional"
KFMIN=5.74.0
PVCUT=$(ver_cut 1-3)
QTMIN=5.15.1
VIRTUALX_REQUIRED="test"
inherit ecm kde.org

DESCRIPTION="KDE Plasma workspace"

LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="appstream +calendar +fontconfig geolocation gps qalculate screencast +semantic-desktop systemd telemetry"

REQUIRED_USE="gps? ( geolocation )"
RESTRICT+=" test"

BDEPEND="virtual/pkgconfig"
COMMON_DEPEND="
>=dev-libs/wayland-1.15
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
>=dev-qt/qtgui-${QTMIN}:5=[jpeg]
>=dev-qt/qtnetwork-${QTMIN}:5
>=dev-qt/qtsql-${QTMIN}:5
>=dev-qt/qtsvg-${QTMIN}:5
>=dev-qt/qtwayland-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
>=dev-qt/qtx11extras-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=kde-frameworks/kactivities-${KFMIN}:5
>=kde-frameworks/kactivities-stats-${KFMIN}:5
>=kde-frameworks/kauth-${KFMIN}:5
>=kde-frameworks/kbookmarks-${KFMIN}:5
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
>=kde-frameworks/kdbusaddons-${KFMIN}:5
>=kde-frameworks/kdeclarative-${KFMIN}:5
>=kde-frameworks/kded-${KFMIN}:5
>=kde-frameworks/kdelibs4support-${KFMIN}:5
>=kde-frameworks/kglobalaccel-${KFMIN}:5
>=kde-frameworks/kguiaddons-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kiconthemes-${KFMIN}:5
>=kde-frameworks/kidletime-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/kitemmodels-${KFMIN}:5
>=kde-frameworks/kitemviews-${KFMIN}:5
>=kde-frameworks/kjobwidgets-${KFMIN}:5
>=kde-frameworks/knewstuff-${KFMIN}:5
>=kde-frameworks/knotifications-${KFMIN}:5
>=kde-frameworks/knotifyconfig-${KFMIN}:5
>=kde-frameworks/kpackage-${KFMIN}:5
>=kde-frameworks/kpeople-${KFMIN}:5
>=kde-frameworks/krunner-${KFMIN}:5
>=kde-frameworks/kservice-${KFMIN}:5
>=kde-frameworks/ktexteditor-${KFMIN}:5
>=kde-frameworks/ktextwidgets-${KFMIN}:5
>=kde-frameworks/kwallet-${KFMIN}:5
>=kde-frameworks/kwayland-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kwindowsystem-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
>=kde-frameworks/plasma-${KFMIN}:5
>=kde-frameworks/prison-${KFMIN}:5[qml]
>=kde-frameworks/solid-${KFMIN}:5
>=kde-plasma/breeze-${PVCUT}:5
>=kde-plasma/kscreenlocker-${PVCUT}:5
>=kde-plasma/kwin-${PVCUT}:5
>=kde-plasma/libkscreen-${PVCUT}:5
>=kde-plasma/libksysguard-${PVCUT}:5
>=kde-plasma/libkworkspace-${PVCUT}:5
>=media-libs/phonon-4.11.0
sys-libs/zlib
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXau
x11-libs/libxcb
x11-libs/libXcursor
x11-libs/libXfixes
x11-libs/libXrender
x11-libs/libXtst
x11-libs/xcb-util
x11-libs/xcb-util-image
appstream? ( dev-libs/appstream[qt5] )
calendar? ( >=kde-frameworks/kholidays-${KFMIN}:5 )
fontconfig? (
media-libs/fontconfig
media-libs/freetype
x11-libs/libXft
x11-libs/xcb-util-image
)
geolocation? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:5 )
gps? ( sci-geosciences/gpsd )
qalculate? ( sci-libs/libqalculate:= )
screencast? (
>=media-video/pipewire-0.3:=
x11-libs/libdrm
)
semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
telemetry? ( dev-libs/kuserfeedback:5 )
"
DEPEND="${COMMON_DEPEND}
>=dev-libs/plasma-wayland-protocols-1.1.1
>=dev-qt/qtconcurrent-${QTMIN}:5
x11-base/xorg-proto
fontconfig? ( x11-libs/libXrender )
"
RDEPEND="${COMMON_DEPEND}
app-text/iso-codes
>=dev-qt/qdbus-${QTMIN}:5
>=dev-qt/qtgraphicaleffects-${QTMIN}:5
>=dev-qt/qtpaths-${QTMIN}:5
>=dev-qt/qtquickcontrols-${QTMIN}:5[widgets]
>=dev-qt/qtquickcontrols2-${QTMIN}:5
>=kde-apps/kio-extras-19.04.3:5
>=kde-frameworks/kdesu-${KFMIN}:5
>=kde-frameworks/kirigami-${KFMIN}:5
>=kde-frameworks/kquickcharts-${KFMIN}:5
>=kde-plasma/ksysguard-${PVCUT}:5
>=kde-plasma/milou-${PVCUT}:5
>=kde-plasma/plasma-integration-${PVCUT}:5
x11-apps/xmessage
x11-apps/xprop
x11-apps/xrdb
x11-apps/xsetroot
systemd? ( sys-apps/dbus[user-session] )
!systemd? ( sys-apps/dbus )
!<kde-plasma/plasma-desktop-5.19.80:5
"
PDEPEND="
>=kde-plasma/kde-cli-tools-${PVCUT}:5
"

PATCHES=(
"${FILESDIR}/${PN}-5.14.2-split-libkworkspace.patch"
"${FILESDIR}/${P}-avoid-render-invisible-contents.patch" # KDE-Bug 347772
"${FILESDIR}/${P}-fix-wake-screensaver-mode-w-keypress.patch" # KDE-Bug 431286
"${FILESDIR}/${P}-fix-crash-on-screen-changes.patch" # KDE-Bug 425711
"${FILESDIR}/${P}-fix-digitalclock-agenda-view.patch" # KDE-Bug 431433
"${FILESDIR}/${P}-wayland-fix-XKB-variable-setup.patch"
"${FILESDIR}/${P}-revert-activate-krunner.patch" # bug 767478
)

src_prepare() {
ecm_src_prepare

cmake_comment_add_subdirectory libkworkspace
# delete colliding libkworkspace translations
if [[ ${KDE_BUILD_TYPE} = release ]]; then
find po -type f -name "*po" -and -name "libkworkspace*" -delete || die
fi

# TODO: try to get a build switch upstreamed
if ! use screencast; then
sed -e "s/^pkg_check_modules.*PipeWire/#&/" \
-i CMakeLists.txt || die
fi
}

src_configure() {
local mycmakeargs=(
-DBUILD_xembed-sni-proxy=OFF
$(cmake_use_find_package appstream AppStreamQt)
$(cmake_use_find_package calendar KF5Holidays)
$(cmake_use_find_package fontconfig Fontconfig)
$(cmake_use_find_package geolocation KF5NetworkManagerQt)
$(cmake_use_find_package qalculate Qalculate)
$(cmake_use_find_package semantic-desktop KF5Baloo)
$(cmake_use_find_package telemetry KUserFeedback)
)

use geolocation && mycmakeargs+=( $(cmake_use_find_package gps libgps) )

ecm_src_configure
}

src_install() {
ecm_src_install

# default startup and shutdown scripts
insinto /etc/xdg/plasma-workspace/env
doins "${FILESDIR}"/10-agent-startup.sh

insinto /etc/xdg/plasma-workspace/shutdown
doins "${FILESDIR}"/10-agent-shutdown.sh
fperms +x /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh
}

pkg_postinst () {
ecm_pkg_postinst

# Clean up pre-5.17.4 dirs
rmdir -v "${EROOT}"/etc/plasma{/startup,/shutdown,} 2> /dev/null

elog "To enable gpg-agent and/or ssh-agent in Plasma sessions,"
elog "edit ${EPREFIX}/etc/xdg/plasma-workspace/env/10-agent-startup.sh"
elog "and ${EPREFIX}/etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
}

0 comments on commit 57de3a3

Please sign in to comment.