Skip to content

Commit

Permalink
dev-ml/ocaml-ctypes: bump to 0.11.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
aballier committed Dec 17, 2016
1 parent d8f61db commit 592be03
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/ocaml-ctypes/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ocaml-ctypes-0.10.2.tar.gz 190090 SHA256 9888667de03c330d3845e8ded0df53f9e1d234be2c3696517a1e98e176116cea SHA512 73374e2063882347fa8458564f8bf49365aa493cb8aa3abcea01c92fc399c1ef0a977df9d87542bd781c6fc6d042dda1c0e13283b550538d173f08df9ce2ce0d WHIRLPOOL ff19c015fb38a1e20fb772b6628fcacce744ca57a42890052b061f6f697fd0bd5d24225de852f734812a623fa63877827993f4b359721b841d0f92b854b2edb3
DIST ocaml-ctypes-0.11.1.tar.gz 202879 SHA256 6be8a5ed4fc2da6051b42aa59648934ea2f9080d783c92f610e91454059b97e2 SHA512 b25beab78ea099d30ef4fdbabfb23eef2eb1dbd9421c3294b632ffda2327c54909913a97837eb25fadb2a0ae6aaf7f4725811845e5a98baa946690b43628b8ce WHIRLPOOL 1c8f1c9045277ea21e5192b08566a4ce363e26ee2b4ab6f5cde77d85965c0080c4ebc7870f827ac91d79f7bcda484c895ce5e4149c451c6b6257b64665bca5e0
DIST ocaml-ctypes-0.11.2.tar.gz 203564 SHA256 708e2c5501ba00b3ed6726a7da1c2b58f607859e8e1cc0381eefd222510488d6 SHA512 f3d75e9e596f68438733090fea8c675624c3b186a77c3adf1eca8f12cc2da336f0f5b1688c2ee788726e873bbb0c4dce1d237d53d1637d78e4ad6a8eae1f912a WHIRLPOOL cbf74628695e01dfe2e379a7c645313e36eaae98f733cda231a290960e52241c96bcc2fb8491daa28b964cf06c0d43a41282767a2d9fa1a4a6f395736eb08864
DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5 SHA512 8155ffe16a58d5714ceb602afa5531c93526defca39a16047328ac06d2c7c7f52b768b18170391f467e1f6919c69275734faf85d27315e11b8bbefcb1bc8afa9 WHIRLPOOL d8d0ef24e0b6c40f50fddf38fed7238cf95573909d2809cc2ab5c1b9b3dab333210e1ce99cf805804576a79d08d819e2ecdee7b4a6a9e13efb13e7b9f88ad802
36 changes: 36 additions & 0 deletions dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit findlib

DESCRIPTION="Library for binding to C libraries using pure OCaml"
HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="test"

RDEPEND="
>=dev-lang/ocaml-4.02:=[ocamlopt]
virtual/libffi
"
DEPEND="${RDEPEND}
test? ( dev-ml/ounit )"

src_compile() {
emake -j1
}

src_test() {
emake -j1 test
}

src_install() {
findlib_src_install
dodoc CHANGES.md README.md
}

0 comments on commit 592be03

Please sign in to comment.