Skip to content

Commit

Permalink
dev-ruby/parallel: add 1.20.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Nov 23, 2020
1 parent 8d3b254 commit 599b0e1
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/parallel/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST parallel-1.19.2.tar.gz 21752 BLAKE2B aac6564ad95d8e366ad079854f22e7dcb149643db5792ee81c84c8c765185e367dedd0e635d2373aeefcd84997da89f9f9f4f6c398e753af4a1ddbf90e428dd0 SHA512 192ce4dc18ecb47522360d0d7022a9e20d72e90ad09889f1b7f29c20c74c980319956f316a35aad0fc7efcd8aac5a635da69eebcf78ba34659365df20e402c3c
DIST parallel-1.20.0.tar.gz 20598 BLAKE2B f9e8626bf6430fffecd9aafb54e0c8c4b61f70dd58f7a2faee0e4c83c10c19d8eac419ab3e22fb75942a5c63f729d47d5e64683caa7f24bc304a1cb16862e18c SHA512 dc472a4792bea7b22b6613942a9c640437cb332d879406af2fad3de0f0529983ba92e6ee2e6f2d424e57695f238d44bf6987c6edc3ce5afca4b024b7501d9508
DIST parallel-1.20.1.tar.gz 20807 BLAKE2B 71f0894126837d71cdc3bf1ca7d4040d53dd88e0c917f29d3ebc940c1ff16bde42631aff50df455729a2a33df3e96de5dda5c9913d9ff4b1cde90ef1702883fa SHA512 cd0f6ad673fe432d48de77adc177181d48bcbf43e4c2a9f86b579bc1f7a9f520730ce68be010e6645b87c8ff755c83ccaf53ffd73631b0f239beb9e124b4d527
56 changes: 56 additions & 0 deletions dev-ruby/parallel/parallel-1.20.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby25 ruby26 ruby27"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"

RUBY_FAKEGEM_GEMSPEC="parallel.gemspec"

inherit ruby-fakegem

DESCRIPTION="Run any code in parallel Processes or Threads"
HOMEPAGE="https://github.com/grosser/parallel"
LICENSE="MIT"
SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"

KEYWORDS="~amd64"
SLOT="1"
IUSE="test"

DEPEND+="test? ( sys-process/lsof sys-process/procps )"

ruby_add_bdepend "
test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:6.0 dev-ruby/sqlite3 )"

each_ruby_prepare() {
# Make sure the correct ruby is used for testing
sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
}

all_ruby_prepare() {
sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
sed -i -e '/bundler/ s:^:#:' \
-e '1i require "tempfile"; gem "activerecord", "~>6.0.0"' spec/cases/helper.rb || die
sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die

# Avoid a failing spec regarding to pipes. The spec seems like it
# should always fail.
sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
-i spec/parallel_spec.rb || die

# Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die

# Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
}

each_ruby_test() {
# Set RUBYLIB explicitly for the ruby's that get started from the specs.
TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
}

0 comments on commit 599b0e1

Please sign in to comment.