Skip to content

Commit

Permalink
games-action/powermanga: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Jul 18, 2016
1 parent 1dc2fb3 commit 59ac698
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 2 deletions.
4 changes: 2 additions & 2 deletions games-action/powermanga/files/powermanga-0.93.1-flags.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- configure.ac.orig 2015-07-12 17:31:49.673817375 -0400
+++ configure.ac 2015-07-12 17:32:18.567700880 -0400
--- a/configure.ac 2015-07-12 17:31:49.673817375 -0400
+++ b/configure.ac 2015-07-12 17:32:18.567700880 -0400
@@ -54,7 +54,7 @@
AC_DEFINE(USE_MALLOC_WRAPPER, 1, Define to use a malloc wrapper)
CFLAGS="-Wall -Werror -pedantic -Wextra -std=gnu99 -g $CFLAGS"
Expand Down
76 changes: 76 additions & 0 deletions games-action/powermanga/powermanga-0.93.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils autotools user

DESCRIPTION="An arcade 2D shoot-em-up game"
HOMEPAGE="http://linux.tlk.fr/"
SRC_URI="http://linux.tlk.fr/games/Powermanga/download/${P}.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND=">=media-libs/libsdl-1.2[sound,joystick,video]
media-libs/libpng:0
media-libs/sdl-mixer[mod]
x11-libs/libX11
x11-libs/libXext
x11-libs/libXxf86dga"
DEPEND=${RDEPEND}

PATCHES=(
"${FILESDIR}"/${P}-flags.patch
)

pkg_setup(){
enewgroup gamestat 36
}

src_prepare() {
default

local f
for f in src/assembler.S src/assembler_opt.S ; do
einfo "patching $f"
cat <<-EOF >> ${f}
#if defined(__linux__) && defined(__ELF__)
.section .note.GNU-stack,"",%progbits
#endif
EOF
done
eautoreconf
}

src_install() {
newbin src/powermanga powermanga.bin
doman powermanga.6
dodoc AUTHORS CHANGES README

insinto "/usr/share/${PN}"
doins -r data sounds graphics texts

find "${D}/usr/share/${PN}" -name "Makefil*" -execdir rm -f \{\} +

dodir "/var/games/${PN}"
fowners root:gamestat /var/games/${PN} /usr/bin/${PN}.bin
fperms 660 /var/games/${PN}
fperms 2755 /usr/bin/${PN}.bin

local f
for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard ; do
touch "${D}/var/games/${f}" || die
fperms 660 "/var/games/${f}"
done

make_wrapper powermanga powermanga.bin "/usr/share/${PN}"
make_desktop_entry powermanga Powermanga
}

pkg_postinst() {
ewarn "NOTE: The highscore file format has changed."
ewarn "Older highscores will not be retained."
}

0 comments on commit 59ac698

Please sign in to comment.