Skip to content

Commit

Permalink
dev-ruby/rubygems: add 3.1.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Dec 26, 2019
1 parent d6e6f25 commit 5a867a4
Show file tree
Hide file tree
Showing 3 changed files with 163 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rubygems/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST rubygems-2.7.10.tgz 863618 BLAKE2B 26a453d2808cbf03caa6f2ef4a829418de58f4ed
DIST rubygems-3.0.3.tgz 904175 BLAKE2B d99de4bdd51779ab214bc4a81f55483341a2c193d4304b8eeb6105cb95877e0a33fe03d93c47433ad3c6bdc8d3e453e33ffb799fd36164feac31616f95eeced4 SHA512 1dd585243341901c7b4cc60a4902000c10ce57fe2cc9c28e27e274a2e6029f936cde1c99d7097c93c2c5b2c8bcee5d692c8fe5cc00c996a040e4954b674e330e
DIST rubygems-3.0.4.tgz 883664 BLAKE2B d5ec493657c055561aa9c0c09719529857706db197bf266ef4c51e48e6f97c08d85a8923b0c6fd72b3fd6ecb584533ff8ca56515c555e9c5b786b0d99ad2a16e SHA512 887c64226ec0b32d33f2ea331936683406d54dc74d19e658a23521e25ab50aa23534fe9eecaf696154247ad1df1d24c233d8900b9aabc79096eebd6afef3f775
DIST rubygems-3.0.6.tgz 887156 BLAKE2B 685cfb108cc684ecbbcee6fe341baa429ac28f331b3db444c5ed3557bc169147dddc8d226780a85842bf1de2e24f6a60b0464820afa2a6838221c22543a36daa SHA512 1ef1822a2b19790a36a6d242b7d4584222617baa27787ec58961a9cfeb2733f19f9085490ffc72ee375d3153c7114e050c42e68fc8039e727fe5961b09365ee5
DIST rubygems-3.1.2.tgz 995386 BLAKE2B bddf5dfc3568402257a2218642e6a15fe904b837114b9ce3a1aad155b235e42d96b1b0d4c6be1ee2e71712b8f1876902c343afdcb6d191ae0a6560f582cb282c SHA512 707525a98d14d46e69922e1deecd3b6c4caa090ee8113ba43b3912dc615cd2b1e0a083ecd0876a08b69c209bc05bba67d179f70d65aca45a92ac543170f13d39
63 changes: 63 additions & 0 deletions dev-ruby/rubygems/files/gentoo-defaults-4.rb
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# frozen_string_literal: true

# Gentoo defaults for rubygems 3.x
#
# Gentoo policy is to install all manually installed code into
# /usr/local and to keep /usr managed by Gentoo. This policy file
# ensures that all manually installed gems using "gem install" are
# installed in /usr/local. Gentoo gems are installed in /usr.

# TODO: We used to manipulate the default_dir, but this no longer
# works since this is now the base for the new "default" gems that
# ruby 2.6 uses with irb. So default_dir should refer to the system
# default now. rubygems also provides various hooks so we may be able
# to use those to install gems in /usr/local by default in a less
# intrusive way.
module Gem

class << self
def portage_gems_dir
RbConfig::CONFIG['sitelibdir'].gsub('site_ruby', 'gems')
end

def local_dir
portage_gems_dir.gsub('@GENTOO_PORTAGE_EPREFIX@/usr',
'@GENTOO_PORTAGE_EPREFIX@/usr/local')
end

def install_dir
Process.euid.zero? ? local_dir : user_dir
end

undef :default_path
def default_path
path = []
path << user_dir if user_home && File.exist?(user_home)
path << default_dir
path << vendor_dir if vendor_dir && File.directory?(vendor_dir)
path << local_dir
path << portage_gems_dir
end

def system_config_path
'@GENTOO_PORTAGE_EPREFIX@/etc'
end

# Set Gentoo defaults for gem commands
begin
undef :operating_system_defaults
rescue NameError
# Avoid either runtime errors or redefinition warnings since
# this method is not present in all rubygem versions distributed
# with dev-lang/ruby.
end
def operating_system_defaults
{
'install' => "--install-dir #{install_dir}",
'uninstall' => "--install-dir #{install_dir}",
'update' => "--install-dir #{install_dir}"
}
end

end
end
99 changes: 99 additions & 0 deletions dev-ruby/rubygems/rubygems-3.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby24 ruby25 ruby26"

inherit ruby-ng prefix

DESCRIPTION="Centralized Ruby extension management system"
HOMEPAGE="https://rubygems.org/"
LICENSE="GPL-2 || ( Ruby MIT )"

SRC_URI="https://rubygems.org/rubygems/${P}.tgz"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT="0"
IUSE="server test"
RESTRICT="!test? ( test )"

PDEPEND="server? ( =dev-ruby/builder-3* )"

ruby_add_bdepend "
test? (
dev-ruby/json
dev-ruby/minitest:5
dev-ruby/rake
dev-ruby/rdoc
)"

all_ruby_prepare() {

mkdir -p lib/rubygems/defaults || die
cp "${FILESDIR}/gentoo-defaults-4.rb" lib/rubygems/defaults/operating_system.rb || die

eprefixify lib/rubygems/defaults/operating_system.rb

# Disable broken tests when changing default values:
sed -i -e '/test_default_path/,/^ end/ s:^:#:' test/rubygems/test_gem.rb || die
# Avoid test that won't work as json is also installed as plain ruby code
sed -i -e '/test_realworld_default_gem/askip "gentoo"' test/rubygems/test_require.rb || die

# Update manifest after changing files to avoid a test failure
rake update_manifest || die
}

each_ruby_compile() {
# Not really a build but...
sed -i -e 's:#!.*:#!'"${RUBY}"':' bin/gem
}

each_ruby_test() {
# Unset RUBYOPT to avoid interferences, bug #158455 et. al.
#unset RUBYOPT

if [[ "${EUID}" -ne "0" ]]; then
RUBYLIB="$(pwd)/lib${RUBYLIB+:${RUBYLIB}}" ${RUBY} --disable-gems -I.:lib:test:bundler/lib \
-e 'require "rubygems"; gem "minitest", "~>5.0"; Dir["test/**/test_*.rb"].each { |tu| require tu }' || die "tests failed"
else
ewarn "The userpriv feature must be enabled to run tests, bug 408951."
eerror "Testsuite will not be run."
fi
}

each_ruby_install() {
# Unset RUBYOPT to avoid interferences, bug #158455 et. al.
unset RUBYOPT
export RUBYLIB="$(pwd)/lib${RUBYLIB+:${RUBYLIB}}"

pushd lib &>/dev/null
doruby -r *
popd &>/dev/null

local sld=$(ruby_rbconfig_value 'sitelibdir')
insinto "${sld#${EPREFIX}}" # bug #320813
newins "${FILESDIR}/auto_gem.rb.ruby19" auto_gem.rb

newbin bin/gem $(basename ${RUBY} | sed -e 's:ruby:gem:')
}

all_ruby_install() {
dodoc History.txt README.md

if use server; then
newinitd "${FILESDIR}/init.d-gem_server2" gem_server
newconfd "${FILESDIR}/conf.d-gem_server" gem_server
fi
}

pkg_postinst() {
if [[ ! -n $(readlink "${ROOT}"/usr/bin/gem) ]] ; then
eselect ruby set $(eselect --brief --colour=no ruby show | head -n1)
fi

ewarn
ewarn "To switch between available Ruby profiles, execute as root:"
ewarn "\teselect ruby set ruby(25|26|...)"
ewarn
}

0 comments on commit 5a867a4

Please sign in to comment.