Skip to content

Commit

Permalink
dev-python/pytest-catchlog: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Dec 13, 2015
1 parent 3372ac9 commit 5b0f61c
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pytest-catchlog/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pytest-catchlog-1.1.tar.gz 6540 SHA256 7ad18d77b93d70c4ea30ed4593b164be104efc50a9112a5733304a71f2cb1119 SHA512 7a272874f9fb4231a7b3a42742b752f0f9750fb861abfed0411bf8edae5ab3e67a0a33fe166e485d530a1ecf1834d131d3affcfc43a735fc5d28018ba155129a WHIRLPOOL cf04096c01176fc077c45ca26b5002e10cdc145e3d3ea83cc7594eb2cbaa3a7636ba661253b1a8e47e316407e672c5ee424df10d8026bc6adb2c04499d386d3f
DIST pytest-catchlog-1.2.0.zip 13620 SHA256 e419a4efc706c948fbac2c5e8a35bb6f16edb3bb0643b86ba28b6bc69e792d32 SHA512 9ab42f5bcec14ab452c1466a7a148270e25c2bda722739101a48802ec61b7cef5099605330c29e46b68d2e7c7452d93b6ca1402e80d083f8e2deec02d38e743a WHIRLPOOL 77a8c24e11ca4da9e42b212b7b022c27f2166a8e559a94f0744dc81aaafd7d3ccfd20b2413cf061bc1c2ea85e540c8a6c7e77a7aff0d1d68587c80ed97e94568
DIST pytest-catchlog-1.2.1.zip 17263 SHA256 9e9ecdeff56666f8a2fd1bee2f6ca3b1be30f1fcfb17fdf9bbd0e95d53feec83 SHA512 c8589d6050dce214525b19055e1dfa93400d274f5b037177e5545bb9098527b9c4988fb2d1b95f2dc4412b1045ea6dff13ba88553f2f03059560286a8f8712d0 WHIRLPOOL 0b36f5b0c7ca86d8381c3b4fe27d8f757f5d56aa0b2f0da07fe1ad72214e91279014798e7b88b8f76c419b751ae30c652a7cb56270fc8ce31fc6b8418313ce57
29 changes: 29 additions & 0 deletions dev-python/pytest-catchlog/pytest-catchlog-1.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="py.test plugin to catch log messages, fork of pytest-capturelog"
HOMEPAGE="https://pypi.python.org/pypi/pytest-catchlog https://github.com/eisensheng/pytest-catchlog"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"

SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

RDEPEND=">=dev-python/py-1.1.1[${PYTHON_USEDEP}]"
DEPEND="
test? (
${RDEPEND}
>=dev-python/pytest-2.7.1[${PYTHON_USEDEP}]
)"

python_test() {
PYTEST_PLUGINS=${PN/-/_} py.test -v -v test_pytest_catchlog.py || die
}

0 comments on commit 5b0f61c

Please sign in to comment.