Skip to content

Commit

Permalink
media-libs/lsp-plugins: 1.1.24 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.2, Repoman-2.3.23
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Aug 15, 2020
1 parent 021fdd5 commit 5b491c3
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/lsp-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST lsp-plugins-1.1.10.tar.gz 53837323 BLAKE2B d890e80d2c6bf871053bd53994af597e653c19894b64df8396c54e1b70bd716adacb8ff7ce7946098d96ca64fe0e03aafc7d4d52af342b67b2551fb0dadaff42 SHA512 aedc6a6a421bfb1ad964f6963793cdb2616456044736745a1c3dc27e947b1d6395de1942c2525bc983e654df5335d35466eed16b8f31612119284b024bdce6c2
DIST lsp-plugins-1.1.22.tar.gz 61694018 BLAKE2B 5c14140af797624cf67d61618d22a006c4b02232cef92533244f36b108b58461c56c28379cbdefc8d967de34c3bae91450bc787a0e6ab2ae41f53e4e431a17ff SHA512 6004136b55a990033d22e60af6c418a5ee708aaf0f4263fc3af8097876f7eea6e125a44392468ed8e30a92c0fa44eb65f40d80b25a5f243d3fd4f1c0f3af70d6
DIST lsp-plugins-1.1.24.tar.gz 63809276 BLAKE2B 3d623d4a5b21f2b4dbd7263805b50c9cd9bf19733aeab774983d7a79695015d1e30201f3de46dde950adadcced347f878a272c1c3da9c5f0721c6effda05d9b4 SHA512 20a82594aec51877255ca2808b6c8af03fcfc2f393fdbc6ae6826dd0da17c4a5cb14f02658c1f102600477d7d4d4fc9e24ee3c6a6ef704afc443499a43bd65ec
DIST lsp-plugins-1.1.5.tar.gz 51911033 BLAKE2B ec9b6f3715f1043537ebe35d14abda85b8dfe23d52d335c54c02eb2867753c9b256a5acd71537c95d6da273d054f0e0c9439fe2f81f6d6ced3087de93bfaef60 SHA512 42b9cd102247a0165a32f82a5a7ce05928a9703c80f215783ad67020d1f975d1c334af1f86c9f17e76bea3fd90bcf5c47fff5618875038b3655621880b60a699
DIST lsp-plugins-1.1.7.tar.gz 52408312 BLAKE2B 1763d7aaff60c4bf3185325789925dc7e5ea1052907f0d1ee3af7c09d39d1f49dfdda537c29d1d2e1ed2bd041345fb3f32a444aa403521f6d4fbd7a952f9f7cb SHA512 e98000c98464abc1db75e044bc1b7adb535b94fbe1025a52baf0a2c92bcd21039c9b330e790f0607b4747356aff3f7d4ae20e666a9135108e875057c5459c8ae
52 changes: 52 additions & 0 deletions media-libs/lsp-plugins/lsp-plugins-1.1.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Linux Studio Plugins"
HOMEPAGE="https://lsp-plug.in"

if [[ ${PV} == *9999 ]];then
inherit git-r3
SRC_URI=""
EGIT_REPO_URI="https://github.com/sadko4u/lsp-plugins"
EGIT_BRANCH="devel"
else
SRC_URI="https://github.com/sadko4u/lsp-plugins/archive/${P}.tar.gz"
S="${WORKDIR}/${PN}-${P}"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="LGPL-3"
SLOT="0"
IUSE="doc jack ladspa +lv2"
REQUIRED_USE="|| ( jack ladspa lv2 )"

DEPEND="
dev-libs/expat
media-libs/libsndfile
doc? ( dev-lang/php:* )
jack? (
virtual/jack
x11-libs/cairo[X]
)
ladspa? ( media-libs/ladspa-sdk )
lv2? (
media-libs/lv2
x11-libs/cairo[X]
)
"
RDEPEND="${DEPEND}"
BDEPEND=""

src_compile() {
use doc && MODULES+="doc"
use jack && MODULES+=" jack"
use ladspa && MODULES+=" ladspa"
use lv2 && MODULES+=" lv2"
emake BUILD_MODULES="${MODULES}"
}

src_install() {
emake PREFIX="/usr" DESTDIR="${ED}" LIB_PATH="/usr/$(get_libdir)" install
}

0 comments on commit 5b491c3

Please sign in to comment.