Skip to content

Commit

Permalink
version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
Michael Sterrett committed Nov 30, 2015
1 parent 051dbce commit 5b820db
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/manaplus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST manaplus-1.5.10.24.tar.xz 9452988 SHA256 abc61f6a2d9867e674f2d41fd5418ac972ac27419550a38ac13744caa26f5dae SHA512 249f8b4fc8183259017ebfec41a7ea4b7dd2e952947a4cb2a42dfb88ae1449df60a8569d0823b1ab2b40ee4ef31858e2fd90d741077a1ed0702daf4c8559cdf2 WHIRLPOOL 206b81d3eb9ba9eb34c63e40ee2933289f3cd0c08b4875d1f36375464fa174d2efab1feb1279f232734b7e53123103739f568981887f4c998a725f75b8a0dd33
DIST manaplus-1.5.11.21.tar.xz 9556540 SHA256 57b6e0d8a730f56060062aa0d6e6baafc100860aa2cc4ba5120d21772410aae6 SHA512 145479b9b6912064356f842910c2a5bbb16bacc7372b898d98f237514722bbac4c6f3fe49ee30942b6e38820cfe9d3508ba5ac64b858a6003e27569327729d7d WHIRLPOOL 628009c082219c63f42892881060dff3784ae419d3d6dab95357272774d0d0545a97cf0d7190157e3338ac38e7f821fe9e3a893f24ee10be71ec6ac83c097722
DIST manaplus-1.5.8.15.tar.xz 9399088 SHA256 c9ebf1c106fd04f8b192b4f07b15528a69bd3541f5eeee7cc5ecfa643a1dab9c SHA512 c99f5f782c794f0697242a2191b0eb5062964919abc6122cc88c2eb2bc32e4ce085b10c4d97d926ee72b0bac406db3130fc05d76cb8e6f1241579a115db8d44d WHIRLPOOL fc5600fe2e42f362abe507a99834bdf1810ef643709fba0005a78119728e4f204df8e7ef2672ba8548fd611f48ddb3b9a063a104b216f3c000b3ee52d83eacab
71 changes: 71 additions & 0 deletions games-rpg/manaplus/manaplus-1.5.11.21.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit games

DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
HOMEPAGE="http://manaplus.evolonline.org"
SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls opengl"

RDEPEND="
>=dev-games/physfs-1.0.0
dev-libs/libxml2
media-libs/libpng:0=
media-libs/libsdl2[X,opengl?,video]
media-libs/sdl2-gfx
media-libs/sdl2-image[png]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-net
media-libs/sdl2-ttf
net-misc/curl
sys-libs/zlib
x11-libs/libX11
x11-misc/xdg-utils
x11-apps/xmessage
media-fonts/dejavu
media-fonts/wqy-microhei
media-fonts/liberation-fonts
media-fonts/mplus-outline-fonts
nls? ( virtual/libintl )
opengl? ( virtual/opengl )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"

src_configure() {
CONFIG_SHELL=/bin/bash \
egamesconf \
--with-sdl2 \
--without-internalsdlgfx \
--localedir=/usr/share/locale \
--prefix="/usr" \
--bindir="${GAMES_BINDIR}" \
$(use_with opengl) \
$(use_enable nls)
}

src_install() {
default
dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono.ttf
dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono-bold.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans-bold.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans.ttf
dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-bold.ttf
dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-regular.ttf
dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${GAMES_DATADIR}"/${PN}/data/fonts/wqy-microhei.ttf

prepgamesdirs
}

0 comments on commit 5b820db

Please sign in to comment.