Skip to content

Commit

Permalink
dev-python/testscenarios: Port to py39
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 31, 2020
1 parent e0855f6 commit 5c7a2c8
Showing 1 changed file with 5 additions and 10 deletions.
15 changes: 5 additions & 10 deletions dev-python/testscenarios/testscenarios-0.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )

inherit distutils-r1

Expand All @@ -22,17 +22,12 @@ RDEPEND="

# using pytest for tests since unittest loader fails with py3.5+
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]"

distutils_enable_tests pytest

python_prepare_all() {
# Remove a faulty file from tests, missing a required attribute
rm ${PN}/tests/test_testcase.py || die
distutils-r1_python_prepare_all
}

python_test() {
pytest -vv || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 5c7a2c8

Please sign in to comment.