Skip to content

Commit

Permalink
dev-util/radare2: bump up to 3.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.61, Repoman-2.3.12
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Feb 20, 2019
1 parent 919863b commit 5cce0aa
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/radare2/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST radare2-3.1.3.tar.gz 6662694 BLAKE2B bb4cec7fd05e4d43473ef2e67e8284c4b6a856ca1ef312153fbb236b800ed3e369ac9833d87e00e2aa5a560c7d8f7f9433d4b8aa9a3f01e7fabe3c26c3f3d60e SHA512 75b4966e8d64ffd341c50b22d12653e4ead23352d25a7a1f923ee6cb177bd0a9a16e7c02cbd5b58cf3da03f415168606cd67ed19f594dca75c66114e9c35903f
DIST radare2-3.2.0.tar.gz 6690470 BLAKE2B edfa7d03d72ab3b7ebda6a2c860165c0c53836f4141674581c0f5f5cc1d6dc7a4ea48530d4825342268e057aeca458a0883f6fd70fb4a2d5d052634f32555442 SHA512 9773068568cf71797b0c86837188604130ef9d63e7b7fd115820d8979dde37d259aaea45002c9984e8c3599e9bade53720d3bb1b3635bdad5a2dc73aff54f048
DIST radare2-3.2.1.tar.gz 6690320 BLAKE2B b0c7db6741d463055d054add112a67378f9f2fae34fabd2848bfffebd44308d0e6fefefa6dd7383ad1b508daed8f388a1538debbf0ae4289130b9c06bfd3f3ae SHA512 4f8c64eb02a80ae5e7adce1322d16f08a250be21c674a8f6f0271bfdc8dc41a6f4ef50fef36e012733db5008cffb356489beef9e9b82300372350bef81e13afa
DIST radare2-3.3.0.tar.gz 6730482 BLAKE2B c6e5ad73d9e34986ba86b73e8410d45c3f99f89a567de85ae22314fd120f358db39a5f8ac9d64af027eb5c7223564d003865f2c8be6ee0a331936e46d02145d8 SHA512 4db9d547b72b952babfd67c8cef2b94fdac9d6fd1194fb50b2ebab538d5bbda0bab4b704d5af64ef684ce9311634c8e04465906a1e7e706b211427054fe0721a
56 changes: 56 additions & 0 deletions dev-util/radare2/radare2-3.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1 eutils

DESCRIPTION="unix-like reverse engineering framework and commandline tools"
HOMEPAGE="http://www.radare.org"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/radare/radare2"
else
SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="ssl libressl"

RDEPEND="
dev-libs/capstone:0=
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_configure() {
econf \
--without-libuv \
--with-syscapstone \
$(use_with ssl openssl)
}

src_install() {
default

insinto /usr/share/zsh/site-functions
doins doc/zsh/_*

newbashcomp doc/bash_autocompletion.sh "${PN}"
bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2

# a workaround for unstable $(INSTALL) call, bug #574866
local d
for d in doc/*; do
if [[ -d $d ]]; then
rm -rfv "$d" || die "failed to delete '$d'"
fi
done
}

0 comments on commit 5cce0aa

Please sign in to comment.