Skip to content

Commit

Permalink
dev-util/ddd: switch to EAPI 6, add elog to fix bug 459324
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
reavertm committed Jun 19, 2017
1 parent 65fb0b6 commit 5d83216
Showing 1 changed file with 20 additions and 16 deletions.
36 changes: 20 additions & 16 deletions dev-util/ddd/ddd-3.3.12-r4.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="4"
EAPI="6"

inherit autotools-utils eutils
inherit autotools eutils

DESCRIPTION="Graphical front-end for command-line debuggers"
HOMEPAGE="https://www.gnu.org/software/ddd"
Expand All @@ -12,11 +12,11 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-3 FDL-1.1"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux"
SLOT="0"
IUSE="+gnuplot readline"
IUSE="readline"

COMMON_DEPEND="
sys-devel/gdb
sys-libs/ncurses
sys-libs/ncurses:*
x11-libs/libX11
x11-libs/libXaw
x11-libs/libXmu
Expand All @@ -25,14 +25,13 @@ COMMON_DEPEND="
>=x11-libs/motif-2.3:0
ppc? ( dev-libs/elfutils )
ppc64? ( dev-libs/elfutils )
readline? ( sys-libs/readline )
readline? ( sys-libs/readline:* )
"
DEPEND="${COMMON_DEPEND}
x11-proto/xproto
"
RDEPEND="${COMMON_DEPEND}
x11-apps/xfontsel
gnuplot? ( sci-visualization/gnuplot )
"

RESTRICT="test"
Expand All @@ -49,38 +48,43 @@ DOCS=(
doc/ddd{-paper.ps,.pdf,-themes.pdf}
)

AUTOTOOLS_AUTORECONF=1
src_prepare() {
default
eautoreconf
}

src_configure() {
local myeconfargs=(
--disable-static
econf \
--disable-static \
$(use_with readline)
)
autotools-utils_src_configure
}

src_install() {
# Remove app defaults
rm -f "${S}"/ddd/Ddd

# Install ddd distribution
autotools-utils_src_install
default

# Install application icon
doicon "${S}"/icons/ddd.xpm
}

pkg_postinst() {
if ! use gnuplot; then
if ! has_version sci-visualization/gnuplot; then
echo
elog "To enable data visualization in DDD, install sci-visualization/gnuplot,"
elog "or re-emerge DDD with gnuplot USE flag (recommended)."
elog "To enable data visualization in DDD, install sci-visualization/gnuplot."
elog "For flat file package.use layout:"
elog " echo '${CATEGORY}/${PN} gnuplot' >> /etc/portage/package.use && emerge -va gnuplot"
elog "For directory package.use layout:"
elog " echo '${CATEGORY}/${PN} gnuplot' > /etc/portage/package.use/ddd && emerge -va gnuplot"
elog
fi
echo
elog "Important notice: if you encounter DDD crashes during visualization, you might"
elog "have hit bug #459324. Try switching to plotting in external window:"
elog "Select Edit|Preferences|Helpers and switch 'plot window' to 'external'"
elog
elog "To be able to debug java, bash, perl or python scripts within DDD, install respectively:"
elog " virtual/jdk"
elog " app-shells/bashdb"
Expand Down

0 comments on commit 5d83216

Please sign in to comment.