Skip to content

Commit

Permalink
app-portage/repoman: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
dol-sen committed Jul 18, 2017
1 parent d675c6e commit 5e6a742
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/repoman/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST repoman-2.3.0.tar.bz2 75285 SHA256 e67d1a2dbb89f44e64a49259e64affcf138ade8a
DIST repoman-2.3.0_rc1.tar.bz2 74621 SHA256 e1de34b710cd43787a91ab49e0b0a6ca32d942ee130ec74523b00f3c5f4ccefa SHA512 7594053472512ab66a269acd1e5f3a9191a519df061ed65b612af0ee30f830ff71ab6b602416aa968476fec1f534ecf313317a28df6120b74c7379197b769983 WHIRLPOOL 9e00736856879f222eaa2f8330109e92b8c7d262ed5a1ef0cf0c3c36f84dfdedfea2de202043aba7585f42353e1ebaf04b16329c812d7e71f957cf697899abd0
DIST repoman-2.3.1.tar.bz2 76678 SHA256 93a39ff20eac6166ec29497ae2476cc168ea35d8822aaed33a3010fe9c2abf91 SHA512 6655027acaa6b98b7fdf927b6744e87b6ea09fe6d61653874aeb5603943aa9fc68df9435335dfc8f51d25949354660eaccdd1c8b659dbc87aea7a2f8bf3dfd16 WHIRLPOOL 29ddd58a8585a3926853beb66afe5d1a41a16667c9155b7dbc08a63ec02ea8873b304ac7267e3525341cd49c15dcc0dc01e0d0802c61a438fb75b113b7aafd66
DIST repoman-2.3.2.tar.bz2 77218 SHA256 69b6ed4fae2475f4b4faa4117498caa943ec8e9e360cd5551e819abc7315d19c SHA512 262dfa8d018b318df695003ec1f370d0d2065f50594cfc2c2ef26989409f61d43e6c0e42d279ed1e316e2a9027ca3fd6e46a06b95d80700d57e0bc3e3713cb6c WHIRLPOOL b571a759717af651737047d13dd35f122d982a73091f2c4509ff4e45301badf947ecd10668f10ef5cb865eb0b0e49133ceb4561d9872bde9bc4de7cbbd524360
DIST repoman-2.3.3.tar.bz2 78045 SHA256 8e8fdb81e3c1f0a7a1d49b161083fa39d47883b3b2bb6ff9456d23f41a75b807 SHA512 17212c19b14817a8a004619dd56ad557457d45919da45edfb27538304e68187fe1104f0b6ccc2b29fa1709645a7a82c75676b118b20d79dc790b0eb2ebf5a2ce WHIRLPOOL b4533763b06ef3e1e2e885bcc5340e05a4d8ab32d47856cbe48920066dcbdb4ce3fd867bef17eecd0caeb91e5481fefdab020e6046518145331727c9496a7a15
78 changes: 78 additions & 0 deletions app-portage/repoman/repoman-2.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
PYTHON_REQ_USE='bzip2(+)'

inherit distutils-r1

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
S="${WORKDIR}/${P}/repoman"
else
SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"

LICENSE="GPL-2"
SLOT="0"
IUSE=""

RDEPEND="
>=sys-apps/portage-2.3.0_rc[${PYTHON_USEDEP}]
>=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"

python_prepare_all() {
distutils-r1_python_prepare_all

if [[ -n "${EPREFIX}" ]] ; then
einfo "Prefixing shebangs ..."

local file
while read -r -d $'\0' file; do
local shebang=$(head -n1 "${file}")

if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "${file}" || \
die "sed failed"
fi
done < <(find . -type f -print0)
fi
}

python_test() {
esetup.py test
}

python_install() {
# Install sbin scripts to bindir for python-exec linking
# they will be relocated in pkg_preinst()
distutils-r1_python_install \
--system-prefix="${EPREFIX}/usr" \
--bindir="$(python_get_scriptdir)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
--sbindir="$(python_get_scriptdir)" \
--sysconfdir="${EPREFIX}/etc" \
"${@}"
}

pkg_postinst() {
einfo ""
einfo "This release of repoman is from the new portage/repoman split"
einfo "release code base."
einfo "This new repoman code base is still being developed. So its API's"
einfo "are not to be considered stable and are subject to change."
einfo "The code released has been tested and considered ready for use."
einfo "This however does not guarantee it to be completely bug free."
einfo "Please report any bugs you may encounter."
einfo ""
}

0 comments on commit 5e6a742

Please sign in to comment.