Skip to content

Commit

Permalink
app-text/liblangtag: Add USE=debug,doc and sync ebuild fixes
Browse files Browse the repository at this point in the history
Gentoo-bug: 593240

0.6.0 Version bump overlapped with commit 4323840

Package-Manager: portage-2.3.0
  • Loading branch information
a17r authored and akhuettel committed Sep 17, 2016
1 parent d785e72 commit 5e6ab7b
Showing 1 changed file with 54 additions and 0 deletions.
54 changes: 54 additions & 0 deletions app-text/liblangtag/liblangtag-0.6.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils xdg-utils

DESCRIPTION="An interface library to access tags for identifying languages"
HOMEPAGE="https://tagoh.bitbucket.org/liblangtag/"
SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"

LICENSE="|| ( LGPL-3 MPL-2.0 )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="debug doc introspection static-libs test"

RDEPEND="
dev-libs/libxml2
introspection? ( dev-libs/gobject-introspection )
"
DEPEND="${RDEPEND}
sys-devel/gettext
doc? ( dev-util/gtk-doc )
introspection? ( dev-libs/gobject-introspection-common )
test? ( dev-libs/check )
"

# Upstream expect liblangtag to be installed when one runs tests...
RESTRICT="test"

PATCHES=( "${FILESDIR}"/${P}-enum.patch )

src_prepare() {
default
xdg_environment_reset
if [[ -d docs/html ]]; then
rm -r docs/html || die "Failed to remove existing gtk-doc"
fi
}

src_configure() {
econf \
$(use_enable debug) \
$(use_enable doc gtk-doc) \
$(use_enable introspection) \
$(use_enable static-libs static) \
$(use_enable test)
}

src_install() {
default
prune_libtool_files --all
}

0 comments on commit 5e6ab7b

Please sign in to comment.