Skip to content

Commit

Permalink
games-arcade/xrick: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 25, 2018
1 parent f0e4141 commit 5ef981f
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 2 deletions.
4 changes: 2 additions & 2 deletions games-arcade/xrick/files/xrick-021212-zlib.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- include/unzip.h.old 2012-03-24 16:13:16.012854948 +0100
+++ include/unzip.h 2012-03-24 16:15:42.744346771 +0100
--- a/include/unzip.h.old 2012-03-24 16:13:16.012854948 +0100
+++ b/include/unzip.h 2012-03-24 16:15:42.744346771 +0100
@@ -49,6 +49,10 @@
#include "zlib.h"
#endif
Expand Down
54 changes: 54 additions & 0 deletions games-arcade/xrick/xrick-021212-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop

DESCRIPTION="Clone of the Rick Dangerous adventure game from the 80's"
HOMEPAGE="http://www.bigorno.net/xrick/"
SRC_URI="http://www.bigorno.net/xrick/${P}.tgz"

LICENSE="GPL-1+ xrick"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
RESTRICT="mirror bindist" # bug #149097

DEPEND="media-libs/libsdl[video]"
RDEPEND="${DEPEND}"

src_unpack() {
unpack ${A}
cd "${S}"
unpack ./xrick.6.gz
}

src_prepare() {
default
eapply "${FILESDIR}"/${P}*.patch
sed -i \
-e "/^run from/d" \
-e "/data.zip/ s:the directory where xrick is:$(get_libdir)/${PN}.:" \
xrick.6 || die

sed -i \
-e "s:data.zip:/usr/$(get_libdir)/${PN}/data.zip:" \
src/xrick.c || die

sed -i \
-e "s/-g -ansi -pedantic -Wall -W -O2/${CFLAGS}/" \
-e '/LDFLAGS/s/=/+=/' \
-e '/CC=/d' \
-e "/CPP=/ { s/gcc/\$(CC)/; s/\"/'/g }" \
Makefile || die
}

src_install() {
dobin xrick
insinto /usr/"$(get_libdir)"/${PN}
doins data.zip
newicon src/xrickST.ico ${PN}.ico
make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico
dodoc README KeyCodes
doman xrick.6
}

0 comments on commit 5ef981f

Please sign in to comment.