Skip to content

Commit

Permalink
sci-visualization/dash: add dash
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed May 12, 2021
1 parent 028d6b9 commit 5f6bb02
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-visualization/dash/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST dash-1.20.0.tar.gz 1786368 BLAKE2B 2826336f72b9bea80be6ef77df49109b7b68ed93678b606c998a1906907551551a3228e1140d20c6e1b5bf5e53fb9cebd0c0a4d7ab5cc1a590e47ef351558a40 SHA512 670cf593068370c70f1db25c70c7a76ce98c696efbff1146cc90f90a99b8b48bf80cf47688504d173ef253ccb9f1170c2067b3af9414eacb226f7ef25149ffff
51 changes: 51 additions & 0 deletions sci-visualization/dash/dash-1.20.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1

DESCRIPTION="Python framework for building ML & data science web apps"
HOMEPAGE="https://github.com/plotly/dash"
SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND=""
RDEPEND="${DEPEND}
dev-python/future[${PYTHON_USEDEP}]
sci-visualization/dash-table[${PYTHON_USEDEP}]
sci-visualization/dash-html-components[${PYTHON_USEDEP}]
sci-visualization/dash-core-components[${PYTHON_USEDEP}]
dev-python/plotly[${PYTHON_USEDEP}]
dev-python/flask-compress[${PYTHON_USEDEP}]"
BDEPEND=""

src_prepare() {
distutils-r1_src_prepare
cd dash-renderer
distutils-r1_src_prepare
}

src_configure() {
distutils-r1_src_configure
cd dash-renderer
distutils-r1_src_configure
}

src_compile() {
distutils-r1_src_compile
cd dash-renderer
distutils-r1_src_compile
}

src_install() {
distutils-r1_src_install
cd dash-renderer
distutils-r1_src_install
}
29 changes: 29 additions & 0 deletions sci-visualization/dash/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Tupone Alfredo</name>
</maintainer>
<longdescription lang="en">
Dash is a productive Python framework for building web analytic
applications.
Written on top of Flask, Plotly.js, and React.js, Dash is ideal for
building data visualization apps with highly custom user interfaces in
pure Python. It's particularly suited for anyone who works with data in
Python.
Through a couple of simple patterns, Dash abstracts away all of the
technologies and protocols that are required to build an interactive
web-based application. Dash is simple enough that you can bind a user
interface around your Python code in an afternoon.
Dash apps are rendered in the web browser. You can deploy your apps to
servers and then share them through URLs. Since Dash apps are viewed in
the web browser, Dash is inherently cross-platform and mobile ready.
Dash ships with supercharged components for interactive user
interfaces. A core set of components, written and maintained by the
Dash team, is available in the dash-core-components library.
</longdescription>
<upstream>
<remote-id type="github">plotly/dash</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 5f6bb02

Please sign in to comment.