Skip to content

Commit

Permalink
dev-python/pysnmp: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Jeroen Roovers committed Jun 20, 2017
1 parent 6140fa2 commit 604d242
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pysnmp/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pysnmp-4.3.3.tar.gz 403779 SHA256 c837d35cbb2c1e067b7b8ed752d962481ef8d7ff11e4cdd8bfb0840c4a786318 SHA512 4b3e4a1785a852eb0b03266d2efbc586c01030f4653482bfea91b64a78098554589e76d38fe43c6b2d734ea3624a42878a2e3b6b7cfbf883e8bf8ad07ff43f81 WHIRLPOOL f04c9f6eece5d31bb4941cfdbfa3216fb5a65b2b2b1b097bd72ca500506262c0458d6d774b99c766f2016fb46ea50bc9a8b741825f820a0a7970dac7ac934977
DIST pysnmp-4.3.5.tar.gz 404793 SHA256 38253fe95cea33f352fb36e85f3c2874043401724300c4888df74835161169d2 SHA512 0878ff1b42a28aaea9ed97137971d606457ae392b701eb7a2f6fd5eb59349e7d2ca1193a3d468ad83ee3eb91cd74ec160c7d90ef750164a717c0ae57fcef5784 WHIRLPOOL 5bfc88686232bdad59208984588418b3811d6d92dc58a0d5e0a18364eb44d99032981a5ee65a3f9fdbf7947e2bd6038763d44880ab19e59ff4611df824e06134
DIST pysnmp-4.3.7.tar.gz 424464 SHA256 fd0e139bf3768eaaa1e2b339c23c19a74c8086fe4307252e2e5b4c3a070d89db SHA512 c6c5f8927b9e142cfd0731ad2e2fc0b9e479b9e2e177acdd2e49e9e8744dd248a0dc79e05066389ad16ca869a88abc44cde1e987fa5ec2ee92f5d2ffb02c8560 WHIRLPOOL 590ac6f51407ba9f66ee108d7dccbe6d362a0b0f57bf2fba1c0d30b7e02a8006f80e8c8a98f88435722fe1928e919967eecd0c628a632e23e1ff212a8c22b254
DIST pysnmp-4.3.8.tar.gz 424591 SHA256 882c1d3edfafad83eea7c29c13f566acc757459f18582217dcb9de6cfe86ba2a SHA512 b8e5329f10f9032a6beb790b3eb7ec18f3ed3aeca011abef4a73a4cd6310e70a2a672e5028bddfc8885b8770c23b07f65f4877d06a70059822854529e7f1fd0f WHIRLPOOL 2daad771ee847824dc708b001f37f2aa47caf0ccfffcfd208a080fb8d88443eedf5ee3f42dcac0ec0e473ee44177ba8b0212ff11a0f9fb8bc4a8c47958d696d9
50 changes: 50 additions & 0 deletions dev-python/pysnmp/pysnmp-4.3.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="Python SNMP library"
HOMEPAGE="http://pysnmp.sf.net/ https://pypi.python.org/pypi/pysnmp"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="doc examples"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
RDEPEND="
>=dev-python/pyasn1-0.2.3[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
"

python_compile_all() {
default

if use doc; then
touch docs/source/conf.py
emake -C docs html
fi
}

python_install_all() {
use doc && local HTML_DOCS=( docs/build/html/* )
docinto examples
use examples && dodoc -r examples/* docs/mibs

distutils-r1_python_install_all
}

pkg_postinst() {
elog "You may also be interested in the following packages: "
elog "dev-python/pysnmp-apps - example programs using pysnmp"
elog "dev-python/pysnmp-mibs - IETF and other mibs"
elog "net-libs/libsmi - to dump MIBs in python format"
}

0 comments on commit 604d242

Please sign in to comment.