Skip to content

Commit

Permalink
app-admin/awscli: Bump to 1.22.14
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 26, 2021
1 parent d2ce663 commit 609157e
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@ DIST awscli-1.22.10.tar.gz 2115079 BLAKE2B 72945d915fb932ff2d243eeca8c21976ecbf2
DIST awscli-1.22.11.tar.gz 2116193 BLAKE2B c4e89882e5a8b37172f06ecf9cf911a0598b8a745390d9e73d11ec608d512bdd4831486f6a5dd03774c1df75f23eaec6bd36dd44a9efbb44f3a599c669e48363 SHA512 8c405704e6992996d46711e1410822a5a73f0fdcd1aaa1dddeef37b27863b1378034bd26009ebdd7f986ff120da3b98556819bebd3598279de86a5b845d8f4f3
DIST awscli-1.22.12.tar.gz 2118104 BLAKE2B f5622b5b2c226e7b95a13c9c268853cdf40ed32f78db9e7ceb5a72197c4dbc60af8d4ef67289d10b9705a91802597a186c55ff0c82c8d3489c1a288fca84ea84 SHA512 08135ad41cbba6f8170acd051734314547bf2892835a9d1c0ee878b398e37af573b365910bde6d739aec11fd9ad8d34331248a5ee2d5811424750eaa86b121d5
DIST awscli-1.22.13.tar.gz 2119944 BLAKE2B acbd93c02dfba99993fa181aae01c5c57a322dddfe8e09e7ed08c2aedb7579aac3f570142981f480db14e3c049c59866bae66f5930b6808711f1f47c0d8c9643 SHA512 1fc04c8a303701fa2f0ab48fd6b6a436128a35f314bb2311cc8a6930bcb2b289573a00f17d2ad4ec52985378995ddf5088f6e2251ada5263997ab0259c583eb1
DIST awscli-1.22.14.tar.gz 2120655 BLAKE2B ffba1bea0574830e6eb3e343b5d83a308e19b557ddde981066b93008062c0702bfba47b7ff7ddc86d4f148606cce8089e81525c54a11eef23906ef1df6303af7 SHA512 0585d8f4842b23065a14cd1f73a7ee810d705ab4d2480591ebf13b640d7501ec784fb2000cdc685cbc6c4e996b7d68763ed79d2122bd61e07a0f97822c925d12
DIST awscli-1.22.5.tar.gz 2111679 BLAKE2B 970e472e8de43664d060023fdab9f54ce848c5655d8aa417efeae1b1efb52989fd021817521db9dc9cd64580cabbf0c30f3d0178034bdb1edf41feebbc690f46 SHA512 9177fe9da0fb8e9e28777bbf8f2c3fe089a08851b57a49fecefab43417fff187584638d17394289bf6df3d18d9052fd958bd3fbc8064327120af04a0cbe30494
DIST awscli-1.22.6.tar.gz 2112080 BLAKE2B 5fffb3d5d0cbbcea813114bbfc89df64f58e83135c88ab914ac4327185310075e7e19e34a51e6cf85f9d2e804fb75cc69e2f7967ea69c67ff1987e054b5756c1 SHA512 3bf7cf59f947708c0d8e6ec992498d0e58a1a2ccb6a330bced0e2eece9989ef9097e08034354a6c265da08346e37611862f3dbb96d35d9787d3013f6220b7de2
DIST awscli-1.22.7.tar.gz 2112524 BLAKE2B f3aeaa85d8be945ee2c64e45b1cd74eaa89cd035c4650f2a35144c113c8b073a7856e680fd1c67ee54f382ab4ad593cbe4752b53b2637b3c587ecdfa22b6819e SHA512 07c96caddb099e507b0e9b75dac79249a8b26a1ca43a3be842079dfe8af399647dec5c330e6b75059955c132b0c5e179cac2edb2b814c51b47a7777d7f7d5373
Expand Down
56 changes: 56 additions & 0 deletions app-admin/awscli/awscli-1.22.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1

DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/aws-cli-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"

# botocore is x.(y+1).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"

distutils_enable_tests --install pytest

src_prepare() {
# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die
distutils-r1_src_prepare
}

python_test() {
distutils_install_for_testing
# integration tests require AWS credentials and Internet access
epytest tests/{functional,unit}
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit 609157e

Please sign in to comment.